Advanced Custom Fields: Extended <= 0.9.2.7 - Unauthenticated Sensitive Information Exposure in 'acf[<mapped_field>]' Parameter via {get_user} Template Tag Injection
Strategic Overview
- Status
- Patched in 0.9.2.8
- Affected Plugin
- Advanced Custom Fields: Extended
- Affected Version
<= 0.9.2.7- CVSS
- 7.5High
- Weakness type
- CWE-200 · Exposure of Sensitive Information to an Unauthorized Actor
- CVE
CVE-2026-110305
At a glance
CVE-2026-110305 is a high-severity Exposure of Sensitive Information to an Unauthorized Actor vulnerability in the Advanced Custom Fields WordPress plugin, affecting versions <= 0.9.2.7. It carries a CVSS score of 7.5 (reachable over the network; low attack complexity; high confidentiality impact). Exploitation requires no authentication. The issue is fixed in version 0.9.2.8; sites on affected versions should update now. Disclosed October 2026, reported by Sawyer.
Vulnerability Overview
The Advanced Custom Fields: Extended plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 0.9.2.7 via the process. This makes it possible for unauthenticated attackers to extract sensitive data including the WordPress password hash of any user by injecting a {get_user} template tag that is resolved and written as a publicly readable term name. Exploitation requires that an administrator has configured a public [acfe_form] shortcode page with a Term action using a save.name field mapping — a supported and documented configuration.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user. A successful exploit has high impact on confidentiality.
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
Reaching this weakness in Advanced Custom Fields <= 0.9.2.7 takes no account at all. Sensitive information exposure means data the application intended to keep internal is returned to a caller who should not be able to see it.
The disclosed data — credentials, tokens, customer records or internal paths — is usually worth more as material for a follow-up attack than as an end in itself. For Advanced Custom Fields the fix is 0.9.2.8: builds <= 0.9.2.7 are affected, anything from 0.9.2.8 onward is not.
Remediation
Update to version 0.9.2.8, or a newer patched version
How does WordSec protect against this?
This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Advanced Custom Fields 0.9.2.8 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Other vulnerabilities in Advanced Custom Fields: Extended
- 9.8CVE-2026-94268: Advanced Custom Fields Privilege Escalation
CVE-2026-94268 - 9.8CVE-2026-94267: Advanced Custom Fields: Extended <= 0.9.2.7 RCE
CVE-2026-94267 - 9.8CVE-2026-12526: Advanced Custom Fields: Extended Privilege Escalation
CVE-2026-12526 - 9.8CVE-2026-8809: Advanced Custom Fields: Extended Privilege Escalation
CVE-2026-8809 - 9.8CVE-2025-14533: Advanced Custom Fields: Extended Privilege Escalation
CVE-2025-14533 - 9.8CVE-2025-13486: Advanced Custom Fields RCE in prepare_form
CVE-2025-13486 - 9.1CVE-2026-112311: Advanced Custom Fields Arbitrary File Deletion
CVE-2026-112311 - 7.3CVE-2026-94262: Advanced Custom… Arbitrary Non-Admin Account Takeover
CVE-2026-94262
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C