CVE-2026-94262

Advanced Custom Fields: Extended 0.9.2.7 - Unauthenticated Arbitrary Non-Admin Account Takeover

2026-10-23 00:00
Karthik Ramakrishnan

Strategic Overview

Status
Patched in 0.9.2.8
Affected Version
0.9.2.7
CVSS
7.3High
Weakness type
CWE-287 · Improper Authentication
CVE
CVE-2026-94262
View all Advanced Custom Fields: Extended vulnerabilities

At a glance

CVE-2026-94262 is a high-severity Improper Authentication vulnerability in the Advanced Custom Fields WordPress plugin, affecting versions 0.9.2.7. It carries a CVSS score of 7.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 0.9.2.8; sites on affected versions should update now. Disclosed October 2026, reported by Karthik Ramakrishnan.

Vulnerability Overview

The Advanced Custom Fields: Extended plugin for WordPress is vulnerable to Account Takeover in all versions up to 0.9.2.7. This is due to missing edit_user capability check for non-administrator target accounts in the update_user action validation within the front-end Forms module. This makes it possible for unauthenticated attackers to overwrite arbitrary non-administrator user account credentials and obtain an authenticated session as that account. The site must publish a front-end form whose user-update action maps its target field to a visitor-supplied value rather than the current user.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.

CWE-287: Improper Authentication

Reaching this weakness in Advanced Custom Fields 0.9.2.7 takes no account at all. Improper authentication means the mechanism that proves who a caller is can be satisfied without the secret it was supposed to require.

An attacker authenticates as another user — administrators included — without ever knowing a password, so password policies and login rate limits never come into play. For Advanced Custom Fields the fix is 0.9.2.8: builds 0.9.2.7 are affected, anything from 0.9.2.8 onward is not.

Remediation

Update to version 0.9.2.8, or a newer patched version

How does WordSec protect against this?

This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Advanced Custom Fields 0.9.2.8 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C