Advanced Custom Fields: Extended <= 0.9.2.7 - Unauthenticated Arbitrary File Deletion
Strategic Overview
- Status
- Patched in 0.9.2.8
- Affected Plugin
- Advanced Custom Fields: Extended
- Affected Version
<= 0.9.2.7- CVSS
- 9.1Critical
- Weakness type
- CWE-22 · Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
- CVE
CVE-2026-112311
At a glance
CVE-2026-112311 is a critical-severity Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in the Advanced Custom Fields WordPress plugin, affecting versions <= 0.9.2.7. It carries a CVSS score of 9.1 (reachable over the network; low attack complexity; high integrity, availability impact). Exploitation requires no authentication. The issue is fixed in version 0.9.2.8; sites on affected versions should update now. Disclosed October 2026, reported by furkan.araspro.
Vulnerability Overview
The Advanced Custom Fields: Extended plugin for WordPress is vulnerable to Arbitrary File Deletion due to insufficient file path validation in all versions up to, and including, 0.9.2.7. This makes it possible for unauthenticated attackers to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php).
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user. A successful exploit has high impact on integrity, availability.
CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
Reaching this weakness in Advanced Custom Fields <= 0.9.2.7 takes no account at all. Path traversal happens when user-controlled text is used to build a filesystem path without being constrained to an intended directory, so sequences like ../ walk the resolved path somewhere else.
Depending on the operation, it means reading files outside the intended folder — wp-config.php being the usual target — or writing to and deleting paths the web server can touch. For Advanced Custom Fields the fix is 0.9.2.8: builds <= 0.9.2.7 are affected, anything from 0.9.2.8 onward is not.
Remediation
Update to version 0.9.2.8, or a newer patched version
How does WordSec protect against this?
Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Advanced Custom Fields 0.9.2.8 closes this, and updating the plugin is the step that ends it.
- Firewall
- Login Security
- Alerts
External References
Related records
Other vulnerabilities in Advanced Custom Fields: Extended
- 9.8CVE-2026-94268: Advanced Custom Fields Privilege Escalation
CVE-2026-94268 - 9.8CVE-2026-94267: Advanced Custom Fields: Extended <= 0.9.2.7 RCE
CVE-2026-94267 - 9.8CVE-2026-12526: Advanced Custom Fields: Extended Privilege Escalation
CVE-2026-12526 - 9.8CVE-2026-8809: Advanced Custom Fields: Extended Privilege Escalation
CVE-2026-8809 - 9.8CVE-2025-14533: Advanced Custom Fields: Extended Privilege Escalation
CVE-2025-14533 - 9.8CVE-2025-13486: Advanced Custom Fields RCE in prepare_form
CVE-2025-13486 - 7.3CVE-2026-94262: Advanced Custom… Arbitrary Non-Admin Account Takeover
CVE-2026-94262 - 7.3CVE-2026-80467: Advanced Custom Fields Privilege Escalation
CVE-2026-80467
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C