Advanced Custom Fields: Extended 0.9.2.7 - Unauthenticated Privilege Escalation via Account Takeover
Strategic Overview
- Status
- Patched in 0.9.2.8
- Affected Plugin
- Advanced Custom Fields: Extended
- Affected Version
0.9.2.7- CVSS
- 9.8Critical
- Weakness type
- CWE-639 · Authorization Bypass Through User-Controlled Key
- CVE
CVE-2026-94268
At a glance
CVE-2026-94268 is a critical-severity Authorization Bypass Through User-Controlled Key vulnerability in the Advanced Custom Fields WordPress plugin, affecting versions 0.9.2.7. It carries a CVSS score of 9.8 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). Exploitation requires no authentication. The issue is fixed in version 0.9.2.8; sites on affected versions should update now. Disclosed October 2026, reported by Jakub Herman.
Vulnerability Overview
The Advanced Custom Fields: Extended plugin for WordPress is vulnerable to Privilege Escalation via Account Takeover in all versions up to 0.9.2.7. This is due to insufficient restriction on the frontend user form. This makes it possible for unauthenticated attackers to elevate their privileges by accessing administrative user accounts.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.
CWE-639: Authorization Bypass Through User-Controlled Key
Reaching this weakness in Advanced Custom Fields 0.9.2.7 takes no account at all. Authorization bypass through a user-controlled key, often called insecure direct object reference, means the application looks up a record by an identifier from the request without checking that the caller owns it.
Changing a number in the request is enough to read or modify other users' records, which on commerce and membership sites means customer data. For Advanced Custom Fields the fix is 0.9.2.8: builds 0.9.2.7 are affected, anything from 0.9.2.8 onward is not.
Remediation
Update to version 0.9.2.8, or a newer patched version
How does WordSec protect against this?
This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Advanced Custom Fields 0.9.2.8 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Other vulnerabilities in Advanced Custom Fields: Extended
- 9.8CVE-2026-94267: Advanced Custom Fields: Extended <= 0.9.2.7 RCE
CVE-2026-94267 - 9.8CVE-2026-12526: Advanced Custom Fields: Extended Privilege Escalation
CVE-2026-12526 - 9.8CVE-2026-8809: Advanced Custom Fields: Extended Privilege Escalation
CVE-2026-8809 - 9.8CVE-2025-14533: Advanced Custom Fields: Extended Privilege Escalation
CVE-2025-14533 - 9.8CVE-2025-13486: Advanced Custom Fields RCE in prepare_form
CVE-2025-13486 - 9.1CVE-2026-112311: Advanced Custom Fields Arbitrary File Deletion
CVE-2026-112311 - 7.3CVE-2026-94262: Advanced Custom… Arbitrary Non-Admin Account Takeover
CVE-2026-94262 - 7.3CVE-2026-80467: Advanced Custom Fields Privilege Escalation
CVE-2026-80467
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C