CVE-2026-93900

Simple CAPTCHA with Cloudflare Turnstile <= 1.44.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode Attributes

Strategic Overview

Status
Patched in 1.44.4
Affected Version
<= 1.44.3
CVSS
6.4Medium
Weakness type
CWE-79 · Improper Neutralization of Input During Web Page Generation
CVE
CVE-2026-93900
View all Simple CAPTCHA with Cloudflare Turnstile vulnerabilities

At a glance

CVE-2026-93900 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the Simple CAPTCHA with Cloudflare Turnstile WordPress plugin, affecting versions <= 1.44.3. It carries a CVSS score of 6.4 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Contributor level or above. The issue is fixed in version 1.44.4; sites on affected versions should update now. Disclosed November 2026, reported by Osvaldo Noe Gonzalez Del Rio (Os).

Vulnerability Overview

The Simple CAPTCHA with Cloudflare Turnstile plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'id' attribute of the [gravity-simple-turnstile] shortcode in versions up to, and including, 1.44.3 This is due to insufficient input sanitization and output escaping on the shortcode attribute in the cfturnstile_gravity_shortcode() function: the value is filtered only by esc_html() and sanitize_text_field() (neither of which touches parentheses or dots) and then emitted via esc_js() in a raw JavaScript expression context outside any string literal (esc_js only escapes quotes, backslashes, and newlines). This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.

CWE-79: Improper Neutralization of Input During Web Page Generation

Simple CAPTCHA with Cloudflare Turnstile <= 1.44.3 carries this weakness at cfturnstile_gravity_shortcode(), and reaching it takes an account at Contributor level or above. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.

Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For Simple CAPTCHA with Cloudflare Turnstile the fix is 1.44.4: builds <= 1.44.3 are affected, anything from 1.44.4 onward is not.

Remediation

Update to version 1.44.4, or a newer patched version

How does WordSec protect against this?

An attacker needs Contributor access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Simple CAPTCHA with Cloudflare Turnstile 1.44.4 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C