Simple CAPTCHA with Cloudflare Turnstile <= 1.42.1 - Unauthenticated Arbitrary Shortcode Execution
Strategic Overview
- Status
- Patched in 1.42.3
- Affected Plugin
- Simple CAPTCHA with Cloudflare Turnstile
- Affected Version
<= 1.42.1- CVSS
- 6.5Medium
- Weakness type
- CWE-94 · Improper Control of Generation of Code
- CVE
CVE-2026-85116
At a glance
CVE-2026-85116 is a medium-severity Improper Control of Generation of Code vulnerability in the Simple CAPTCHA with Cloudflare Turnstile WordPress plugin, affecting versions <= 1.42.1. It carries a CVSS score of 6.5 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 1.42.3; sites on affected versions should update now. Disclosed September 2026, reported by Jakub Herman.
Vulnerability Overview
The Simple CAPTCHA with Cloudflare Turnstile plugin for WordPress is vulnerable to Arbitrary Shortcode Execution in all versions up to, and including, 1.42.1. This is due to use of do_shortcode() on the wpcf7_form_elements filter output, which includes user-submitted field values reflected back in the rendered form. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes registered on the site by injecting shortcode strings into Contact Form 7 form fields that are repopulated on the rendered form output.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.
CWE-94: Improper Control of Generation of Code
Simple CAPTCHA with Cloudflare Turnstile <= 1.42.1 carries this weakness at do_shortcode(), and reaching it takes no account at all. Code injection means input from a request reaches a language construct that evaluates code, so the attacker's text is executed rather than treated as data.
The injected code runs with the web server's privileges, giving the attacker the same access to the database and filesystem as WordPress itself. For Simple CAPTCHA with Cloudflare Turnstile the fix is 1.42.3: builds <= 1.42.1 are affected, anything from 1.42.3 onward is not.
Remediation
Update to version 1.42.3, or a newer patched version
How does WordSec protect against this?
Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. Classes like this one can leave something behind, so the staged malware scanner is the second half: it looks for dropped files and modified code rather than for the request that created them. None of that substitutes for the fix: Simple CAPTCHA with Cloudflare Turnstile 1.42.3 closes this, and updating the plugin is the step that ends it.
- Firewall
- Scanner
- Login Security
External References
Related records
Other vulnerabilities in Simple CAPTCHA with Cloudflare Turnstile
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C