Redux Framework <= 4.5.16 - Missing Authorization to Authenticated (Subscriber+) Sensitive Information Disclosure via download_options AJAX Action
Strategic Overview
- Status
- Patched in 4.5.17
- Affected Plugin
- Redux Framework
- Affected Version
<= 4.5.16- CVSS
- 5.3Medium
- Weakness type
- CWE-862 · Missing Authorization
- CVE
CVE-2026-110705
At a glance
CVE-2026-110705 is a medium-severity Missing Authorization vulnerability in the Redux Framework WordPress plugin, affecting versions <= 4.5.16. It carries a CVSS score of 5.3 (reachable over the network; high confidentiality impact). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 4.5.17; sites on affected versions should update now. Disclosed November 2026, reported by HumbertoSP.
Vulnerability Overview
The Redux Framework plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 4.5.16. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to export the entire Redux options panel configuration — including API keys, SMTP credentials, licence keys, and third-party tokens — that is otherwise restricted to administrators. Exploitation requires that a theme or plugin registers a Redux import_export field on a user profile via Redux_Users::set_profile(), which causes the nonce to be printed into the subscriber's own /wp-admin/profile.php page source, making it directly readable without any additional privileges.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, and no interaction from a victim user. A successful exploit has high impact on confidentiality.
CWE-862: Missing Authorization
Redux Framework <= 4.5.16 carries this weakness at set_profile(), and reaching it takes an account at Subscriber level or above. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.
Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For Redux Framework the fix is 4.5.17: builds <= 4.5.16 are affected, anything from 4.5.17 onward is not.
Remediation
Update to version 4.5.17, or a newer patched version
How does WordSec protect against this?
Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Redux Framework 4.5.17 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in Redux Framework
- 8.8CVE-2026-12525: Redux Framework <= 4.5.12 Privilege Escalation
CVE-2026-12525 - 8.8Gutenberg Template and Pattern Library & Redux Framework CSRF
- 7.2CVE-2024-6828: Redux Framework 4.4.12 - 4.4.17 JSON File Upload
CVE-2024-6828 - 7.1CVE-2021-38312: Gutenberg Template Library… Incorrect Authorization
CVE-2021-38312 - 6.8CVE-2025-14123: Redux Framework – Authenticated (Subscriber+)
CVE-2025-14123 - 6.4CVE-2026-110534: Redux Framework <= 4.5.16 Stored Cross-Site Scripting
CVE-2026-110534 - 6.4CVE-2026-104812: Redux Framework <= 4.5.16 Stored Cross-Site Scripting
CVE-2026-104812 - 6.4CVE-2026-120533: Redux Framework <= 4.5.16 Stored Cross-Site Scripting
CVE-2026-120533
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C