CVE-2026-103997

Redux Framework <= 4.5.15 - Missing Authorization to Authenticated (Subscriber+) Sensitive Information Disclosure via /wp-admin/profile.php inline redux_<opt_name> JavaScript

2026-10-30 19:19
Kuba

Strategic Overview

Status
Patched in 4.5.16
Affected Plugin
Redux Framework
Affected Version
<= 4.5.15
CVSS
6.5Medium
Weakness type
CWE-862 · Missing Authorization
CVE
CVE-2026-103997
View all Redux Framework vulnerabilities

At a glance

CVE-2026-103997 is a medium-severity Missing Authorization vulnerability in the Redux Framework WordPress plugin, affecting versions <= 4.5.15. It carries a CVSS score of 6.5 (reachable over the network; low attack complexity; high confidentiality impact). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 4.5.16; sites on affected versions should update now. Disclosed October 2026, reported by Kuba.

Vulnerability Overview

The Redux Framework plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 4.5.15. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to view the entire Redux options payload — including plaintext password field values, API keys, license keys, and SMTP credentials — exposed in the inline redux_<opt_name> JavaScript block on wp-admin/profile.php. The Users extension is loaded automatically for every Redux instance registered by any installed theme or plugin, meaning any site running Redux Framework is affected regardless of whether the developer explicitly configured the Users extension.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality.

CWE-862: Missing Authorization

Reaching this weakness in Redux Framework <= 4.5.15 takes an account at Subscriber level or above. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.

Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For Redux Framework the fix is 4.5.16: builds <= 4.5.15 are affected, anything from 4.5.16 onward is not.

Remediation

Update to version 4.5.16, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Redux Framework 4.5.16 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C