Popup by Supsystic <= 1.10.19 - Missing Authorization to Sensitive Information Exposure
Strategic Overview
- Status
- Patched in 1.10.20
- Affected Version
<= 1.10.19- CVSS
- 4.3Medium
- Weakness type
- CWE-200 · Exposure of Sensitive Information to an Unauthorized Actor
- CVE
CVE-2023-46197
At a glance
CVE-2023-46197 is a medium-severity Exposure of Sensitive Information to an Unauthorized Actor vulnerability in the Customer Engagement System WordPress plugin, affecting versions <= 1.10.19. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). The root cause is a missing authorization check on a reachable function. The issue is fixed in version 1.10.20; sites on affected versions should update now. Disclosed October 2023, reported by Rafshanzani Suhada.
Vulnerability Overview
The Popup by Supsystic plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.10.19 via the getWpCsvList action. This makes it possible for authenticated attackers with subscriber level access or higher to extract sensitive data including subscriber email addresses. CVE-2023-51353 appears to be a duplicate of this issue.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
Reaching this weakness in Customer Engagement System <= 1.10.19 takes a caller who can reach the endpoint. Sensitive information exposure means data the application intended to keep internal is returned to a caller who should not be able to see it.
The disclosed data — credentials, tokens, customer records or internal paths — is usually worth more as material for a follow-up attack than as an end in itself. For Customer Engagement System the fix is 1.10.20: builds <= 1.10.19 are affected, anything from 1.10.20 onward is not.
Remediation
Update to version 1.10.20, or a newer patched version
How does WordSec protect against this?
The fix is the thing that ends this: Customer Engagement System 1.10.20 closes this, and updating the plugin is the step that ends it.
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in Customer Engagement System – Popup Builder, Forms, CRM & Email Marketing Automation
- 9.1CVE-2024-52434: Popup by Supsystic <= 1.10.29 Remote Code Execution
CVE-2024-52434 - 8.8CVE-2026-18322: Smart Popup by Supsystic Privilege Escalation
CVE-2026-18322 - 8.8CVE-2016-10915: Popup by Supsystic < 1.7.9 Cross-Site Request Forgery
CVE-2016-10915 - 8.1CVE-2026-73380: Smart Popup by Supsystic PHP Object Injection
CVE-2026-73380 - 7.2CVE-2026-115225: Customer Engagement System SSRF
CVE-2026-115225 - 7.2CVE-2026-115223: Customer Engagement System RCE
CVE-2026-115223 - 7.2CVE-2026-102398: Smart Popup by Supsystic <= 1.13.1 Stored XSS
CVE-2026-102398 - 7.2CVE-2026-27537: Smart Popup by Supsystic <= 1.11.2 Stored XSS
CVE-2026-27537
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C