Popup by Supsystic <= 1.10.29 - Authenticated (Admin+) Remote Code Execution
Strategic Overview
- Status
- Patched in 1.10.30
- Affected Version
<= 1.10.29- CVSS
- 9.1Critical
- Weakness type
- CWE-1336 · Improper Neutralization of Special Elements Used in a Template Engine
- CVE
CVE-2024-52434
At a glance
CVE-2024-52434 is a critical-severity Improper Neutralization of Special Elements Used in a Template Engine vulnerability in the Customer Engagement System WordPress plugin, affecting versions <= 1.10.29. It carries a CVSS score of 9.1 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). Exploitation requires an authenticated account at Admin level or above. The issue is fixed in version 1.10.30; sites on affected versions should update now. Disclosed November 2024, reported by Hakiduck.
Vulnerability Overview
The Popup by Supsystic plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1.10.29. This makes it possible for authenticated attackers, with Administrator-level access and above, to execute code on the server.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.
CWE-1336: Improper Neutralization of Special Elements Used in a Template Engine
The product uses a template engine to insert or process externally-influenced input, but it does not neutralize or incorrectly neutralizes special elements or syntax that can be interpreted as template expressions or other code directives when processed by the engine.
Remediation
Update to version 1.10.30, or a newer patched version
How does WordSec protect against this?
An attacker needs Admin access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. Classes like this one can leave something behind, so the staged malware scanner is the second half: it looks for dropped files and modified code rather than for the request that created them. None of that substitutes for the fix: Customer Engagement System 1.10.30 closes this, and updating the plugin is the step that ends it.
- Firewall
- Scanner
- Alerts
External References
Related records
Other vulnerabilities in Customer Engagement System – Popup Builder, Forms, CRM & Email Marketing Automation
- 8.8CVE-2026-18322: Smart Popup by Supsystic Privilege Escalation
CVE-2026-18322 - 8.8CVE-2016-10915: Popup by Supsystic < 1.7.9 Cross-Site Request Forgery
CVE-2016-10915 - 8.1CVE-2026-73380: Smart Popup by Supsystic PHP Object Injection
CVE-2026-73380 - 7.2CVE-2026-102398: Smart Popup by Supsystic <= 1.13.1 Stored XSS
CVE-2026-102398 - 7.2CVE-2026-27537: Smart Popup by Supsystic <= 1.11.2 Stored XSS
CVE-2026-27537 - 7.1CVE-2023-3186: Popup by Supsystic <= 1.10.18 Prototype Pollution
CVE-2023-3186 - 6.3CVE-2023-39997: Popup by Supsystic <= 1.10.19 CSRF
CVE-2023-39997 - 6.1CVE-2021-24275: Popup by Supsystic <= 1.10.4 Reflected XSS
CVE-2021-24275
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C