Customer Engagement System – Popup Builder, Forms, CRM & Email Marketing Automation < 2.0.2 - Authenticated (Administrator+) Remote Code Execution
Strategic Overview
- Status
- Patched in 2.0.2
- Affected Version
< 2.0.2- CVSS
- 7.2High
- Weakness type
- CWE-94 · Improper Control of Generation of Code ('Code Injection')
- CVE
CVE-2026-115223
At a glance
CVE-2026-115223 is a high-severity Improper Control of Generation of Code ('Code Injection') vulnerability in the Customer Engagement System WordPress plugin, affecting versions < 2.0.2. It carries a CVSS score of 7.2 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). Exploitation requires an authenticated account at Administrator level or above. The issue is fixed in version 2.0.2; sites on affected versions should update now. Disclosed October 2026, reported by Karthik Ramakrishnan.
Vulnerability Overview
The Customer Engagement System – Popup Builder, Forms, CRM & Email Marketing Automation plugin for WordPress is vulnerable to Remote Code Execution in all versions up to 2.0.2. This is due to insufficient validation of user supplied input before it is executed. This makes it possible for authenticated attackers, with administrator-level access and above, to execute arbitrary code on the server.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.
CWE-94: Improper Control of Generation of Code ('Code Injection')
Reaching this weakness in Customer Engagement System < 2.0.2 takes an account at Administrator level or above. Code injection means input from a request reaches a language construct that evaluates code, so the attacker's text is executed rather than treated as data.
The injected code runs with the web server's privileges, giving the attacker the same access to the database and filesystem as WordPress itself. For Customer Engagement System the fix is 2.0.2: builds < 2.0.2 are affected, anything from 2.0.2 onward is not.
Remediation
Update to version 2.0.2, or a newer patched version
How does WordSec protect against this?
An attacker needs Administrator access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. Classes like this one can leave something behind, so the staged malware scanner is the second half: it looks for dropped files and modified code rather than for the request that created them. None of that substitutes for the fix: Customer Engagement System 2.0.2 closes this, and updating the plugin is the step that ends it.
- Firewall
- Scanner
- Alerts
External References
Related records
Other vulnerabilities in Customer Engagement System – Popup Builder, Forms, CRM & Email Marketing Automation
- 9.1CVE-2024-52434: Popup by Supsystic <= 1.10.29 Remote Code Execution
CVE-2024-52434 - 8.8CVE-2026-18322: Smart Popup by Supsystic Privilege Escalation
CVE-2026-18322 - 8.8CVE-2016-10915: Popup by Supsystic < 1.7.9 Cross-Site Request Forgery
CVE-2016-10915 - 8.1CVE-2026-73380: Smart Popup by Supsystic PHP Object Injection
CVE-2026-73380 - 7.2CVE-2026-115225: Customer Engagement System SSRF
CVE-2026-115225 - 7.2CVE-2026-102398: Smart Popup by Supsystic <= 1.13.1 Stored XSS
CVE-2026-102398 - 7.2CVE-2026-27537: Smart Popup by Supsystic <= 1.11.2 Stored XSS
CVE-2026-27537 - 7.1CVE-2023-3186: Popup by Supsystic <= 1.10.18 Prototype Pollution
CVE-2023-3186
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C