Customer Engagement System – Popup Builder, Forms, CRM & Email Marketing Automation < 2.0.2 - Authenticated (Administrator+) SQL Injection
Strategic Overview
- Status
- Patched in 2.0.2
- Affected Version
< 2.0.2- CVSS
- 4.9Medium
- Weakness type
- CWE-89 · Improper Neutralization of Special Elements used in an SQL Command
- CVE
CVE-2026-115224
At a glance
CVE-2026-115224 is a medium-severity Improper Neutralization of Special Elements used in an SQL Command vulnerability in the Customer Engagement System WordPress plugin, affecting versions < 2.0.2. It carries a CVSS score of 4.9 (reachable over the network; low attack complexity; high confidentiality impact). Exploitation requires an authenticated account at Administrator level or above. The issue is fixed in version 2.0.2; sites on affected versions should update now. Disclosed October 2026, reported by Karthik Ramakrishnan.
Vulnerability Overview
The Customer Engagement System – Popup Builder, Forms, CRM & Email Marketing Automation plugin for WordPress is vulnerable to SQL Injection in all versions up to 2.0.2. This is due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality.
CWE-89: Improper Neutralization of Special Elements used in an SQL Command
Reaching this weakness in Customer Engagement System < 2.0.2 takes an account at Administrator level or above. SQL injection happens when request data is concatenated into a query instead of being bound as a parameter, letting an attacker change the structure of the statement rather than just its values.
A working injection can read any table the database user can see, which on a WordPress install means user records, password hashes and session or API secrets stored in options. For Customer Engagement System the fix is 2.0.2: builds < 2.0.2 are affected, anything from 2.0.2 onward is not.
Remediation
Update to version 2.0.2, or a newer patched version
How does WordSec protect against this?
An attacker needs Administrator access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Customer Engagement System 2.0.2 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in Customer Engagement System – Popup Builder, Forms, CRM & Email Marketing Automation
- 9.1CVE-2024-52434: Popup by Supsystic <= 1.10.29 Remote Code Execution
CVE-2024-52434 - 8.8CVE-2026-18322: Smart Popup by Supsystic Privilege Escalation
CVE-2026-18322 - 8.8CVE-2016-10915: Popup by Supsystic < 1.7.9 Cross-Site Request Forgery
CVE-2016-10915 - 8.1CVE-2026-73380: Smart Popup by Supsystic PHP Object Injection
CVE-2026-73380 - 7.2CVE-2026-115225: Customer Engagement System SSRF
CVE-2026-115225 - 7.2CVE-2026-115223: Customer Engagement System RCE
CVE-2026-115223 - 7.2CVE-2026-102398: Smart Popup by Supsystic <= 1.13.1 Stored XSS
CVE-2026-102398 - 7.2CVE-2026-27537: Smart Popup by Supsystic <= 1.11.2 Stored XSS
CVE-2026-27537
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C