Meow Gallery <= 5.5.4 - Unauthenticated Arbitrary Shortcode Execution
Strategic Overview
- Status
- Patched in 5.5.5
- Affected Plugin
- Meow Gallery
- Affected Version
<= 5.5.4- CVSS
- 5.3Medium
- Weakness type
- CWE-94 · Improper Control of Generation of Code
- CVE
CVE-2026-92422
At a glance
CVE-2026-92422 is a medium-severity Improper Control of Generation of Code vulnerability in the Meow Gallery WordPress plugin, affecting versions <= 5.5.4. It carries a CVSS score of 5.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 5.5.5; sites on affected versions should update now. Disclosed September 2026, reported by JunHee CHO.
Vulnerability Overview
The The Meow Gallery plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 5.5.4. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.
CWE-94: Improper Control of Generation of Code
Reaching this weakness in Meow Gallery <= 5.5.4 takes no account at all. Code injection means input from a request reaches a language construct that evaluates code, so the attacker's text is executed rather than treated as data.
The injected code runs with the web server's privileges, giving the attacker the same access to the database and filesystem as WordPress itself. For Meow Gallery the fix is 5.5.5: builds <= 5.5.4 are affected, anything from 5.5.5 onward is not.
Remediation
Update to version 5.5.5, or a newer patched version
How does WordSec protect against this?
Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. Classes like this one can leave something behind, so the staged malware scanner is the second half: it looks for dropped files and modified code rather than for the request that created them. None of that substitutes for the fix: Meow Gallery 5.5.5 closes this, and updating the plugin is the step that ends it.
- Firewall
- Scanner
- Login Security
External References
Related records
Other vulnerabilities in Meow Gallery
- 8.8Meow Gallery (+ Gallery Block) <= 4.1.9 Arbitrary Options Update
- 8.1CVE-2021-24465: Meow Gallery (+ Gallery Block) <= 4.1.8 SQL Injection
CVE-2021-24465 - 6.5CVE-2026-13747: Meow Gallery Authenticated (Author+) Information
CVE-2026-13747 - 6.5CVE-2026-32418: Meow Gallery <= 5.4.4 SQL Injection
CVE-2026-32418 - 6.4CVE-2026-9239: Meow Gallery <= 5.5.1 Stored Cross-Site Scripting
CVE-2026-9239 - 6.4CVE-2026-15386: Meow Gallery <= 5.5.1 Stored Cross-Site Scripting
CVE-2026-15386 - 6.4CVE-2025-47449: Meow Gallery <= 5.2.7 Stored Cross-Site Scripting
CVE-2025-47449 - 6.4CVE-2024-4386: Gallery Block (Meow Gallery) <= 5.1.3 Stored XSS
CVE-2024-4386
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C