CVE-2026-9239

Meow Gallery <= 5.5.1 - Authenticated (Author+) Stored Cross-Site Scripting via Attachment Alt Text (aria-label attribute)

2026-10-30 17:09
Yat

Strategic Overview

Status
Patched in 5.5.2
Affected Plugin
Meow Gallery
Affected Version
<= 5.5.1
CVSS
6.4Medium
Weakness type
CWE-79 · Improper Neutralization of Input During Web Page Generation
CVE
CVE-2026-9239
View all Meow Gallery vulnerabilities

At a glance

CVE-2026-9239 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the Meow Gallery WordPress plugin, affecting versions <= 5.5.1. It carries a CVSS score of 6.4 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Author level or above. The issue is fixed in version 5.5.2; sites on affected versions should update now. Disclosed October 2026, reported by Yat.

Vulnerability Overview

The Meow Gallery plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Attachment Alt Text (aria-label attribute) in all versions up to, and including, 5.5.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerable code path is only reachable when a gallery item is rendered as a link (i.e., link_href is non-empty), and exploitation relies on the fact that WordPress's sanitize_text_field() strips angle-bracketed tags but preserves double quotes, allowing an attacker to break out of the aria-label attribute context and inject event-handler attributes such as onclick.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.

CWE-79: Improper Neutralization of Input During Web Page Generation

Meow Gallery <= 5.5.1 carries this weakness at sanitize_text_field(), and reaching it takes an account at Author level or above. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.

Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For Meow Gallery the fix is 5.5.2: builds <= 5.5.1 are affected, anything from 5.5.2 onward is not.

Remediation

Update to version 5.5.2, or a newer patched version

How does WordSec protect against this?

An attacker needs Author access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Meow Gallery 5.5.2 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C