Meow Gallery <= 5.5.4 - Missing Authorization to Authenticated (Author+) Information Disclosure via fetch_posts REST Endpoint
Strategic Overview
- Status
- Patched in 5.5.5
- Affected Plugin
- Meow Gallery
- Affected Version
<= 5.5.4- CVSS
- 6.5Medium
- Weakness type
- CWE-862 · Missing Authorization
- CVE
CVE-2026-13747
At a glance
CVE-2026-13747 is a medium-severity Missing Authorization vulnerability in the Meow Gallery WordPress plugin, affecting versions <= 5.5.4. It carries a CVSS score of 6.5 (reachable over the network; low attack complexity; high confidentiality impact). Exploitation requires an authenticated account at Author level or above. The issue is fixed in version 5.5.5; sites on affected versions should update now. Disclosed October 2026, reported by Wordfence PRISM.
Vulnerability Overview
The Meow Gallery plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 5.5.4 This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with author-level access and above, to enumerate and read metadata — including post ID, title, date, author, and status — of all private and draft posts on the site, including those authored by other users.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality.
CWE-862: Missing Authorization
Reaching this weakness in Meow Gallery <= 5.5.4 takes an account at Author level or above. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.
Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For Meow Gallery the fix is 5.5.5: builds <= 5.5.4 are affected, anything from 5.5.5 onward is not.
Remediation
Update to version 5.5.5, or a newer patched version
How does WordSec protect against this?
Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Meow Gallery 5.5.5 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in Meow Gallery
- 8.1CVE-2021-24465: Meow Gallery (+ Gallery Block) <= 4.1.8 SQL Injection
CVE-2021-24465 - 6.5CVE-2026-32418: Meow Gallery <= 5.4.4 SQL Injection
CVE-2026-32418 - 6.4CVE-2026-9239: Meow Gallery <= 5.5.1 Stored Cross-Site Scripting
CVE-2026-9239 - 6.4CVE-2026-15386: Meow Gallery <= 5.5.1 Stored Cross-Site Scripting
CVE-2026-15386 - 6.4CVE-2025-47449: Meow Gallery <= 5.2.7 Stored Cross-Site Scripting
CVE-2025-47449 - 6.4CVE-2024-4386: Gallery Block (Meow Gallery) <= 5.1.3 Stored XSS
CVE-2024-4386 - 5.3CVE-2026-92422: Meow Gallery <= 5.5.4 Arbitrary Shortcode Execution
CVE-2026-92422 - 4.3CVE-2026-92423: Meow Gallery <= 5.5.4 Information Exposure
CVE-2026-92423
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C