CVE-2026-97645

Gravity Forms <= 3.1.2 - Unauthenticated Stored Cross-Site Scripting via List Field

2026-10-29 18:25
Supakiad S. (m3ez)

Strategic Overview

Status
Patched in 3.1.3
Affected Plugin
Gravity Forms
Affected Version
<= 3.1.2
CVSS
7.2High
Weakness type
CWE-79 · Improper Neutralization of Input During Web Page Generation
CVE
CVE-2026-97645
View all Gravity Forms vulnerabilities

At a glance

CVE-2026-97645 is a high-severity Improper Neutralization of Input During Web Page Generation vulnerability in the Gravity Forms WordPress plugin, affecting versions <= 3.1.2. It carries a CVSS score of 7.2 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 3.1.3; sites on affected versions should update now. Disclosed October 2026, reported by Supakiad S. (m3ez).

Vulnerability Overview

The Gravity Forms plugin for WordPress is vulnerable to Stored Cross-Site Scripting via List Field in all versions up to, and including, 3.1.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Successful exploitation requires the administrator to click the injected link in the entry detail view and confirm a dialog, which triggers the admin JavaScript bundle's delegated data-dialog-callback handler to invoke the attacker-supplied function reference.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.

CWE-79: Improper Neutralization of Input During Web Page Generation

Reaching this weakness in Gravity Forms <= 3.1.2 takes no account at all. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.

Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For Gravity Forms the fix is 3.1.3: builds <= 3.1.2 are affected, anything from 3.1.3 onward is not.

Remediation

Update to version 3.1.3, or a newer patched version

How does WordSec protect against this?

Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Gravity Forms 3.1.3 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C