CVE-2026-103039

Gravity Forms <= 3.1.2 - Unauthenticated PHP Object Injection via Post Custom Field

2026-10-29 18:29
Tin Pham (TF1T)

Strategic Overview

Status
Patched in 3.1.3
Affected Plugin
Gravity Forms
Affected Version
<= 3.1.2
CVSS
9.8Critical
Weakness type
CWE-502 · Deserialization of Untrusted Data
CVE
CVE-2026-103039
View all Gravity Forms vulnerabilities

At a glance

CVE-2026-103039 is a critical-severity Deserialization of Untrusted Data vulnerability in the Gravity Forms WordPress plugin, affecting versions <= 3.1.2. It carries a CVSS score of 9.8 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). Exploitation requires no authentication. The issue is fixed in version 3.1.3; sites on affected versions should update now. Disclosed October 2026, reported by Tin Pham (TF1T).

Vulnerability Overview

The Gravity Forms plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 3.1.2 via a Post Custom Field whose input type is List. This is due to GFFormsModel::create_post() passing the submitted value to WordPress' unrestricted global maybe_unserialize() rather than the plugin's own hardened GFCommon::maybe_unserialize(), which was added in 3.1.1 and passes allowed_classes => false precisely to prevent object instantiation. Where the field has a content template enabled, the submitted row reaches that call verbatim. This makes it possible for unauthenticated attackers to inject a PHP object into post meta. No PHP Object Injection gadget chain is present in the plugin itself; however, if a gadget chain is present via an additional plugin or theme, it could allow the attacker to perform actions such as remote code execution. Where the custom field is mapped to the protected _wp_page_template meta key, WordPress itself supplies the chain: validate_file() accepts non-scalars, WP_Theme::__toString() then resolves an attacker-controlled path, and on hosts with a readable PEAR install and register_argc_argv enabled this yields remote code execution.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.

CWE-502: Deserialization of Untrusted Data

Gravity Forms <= 3.1.2 carries this weakness at create_post(), and reaching it takes no account at all. Deserialization of untrusted data means the application reconstructs objects from input a caller controls, letting the attacker choose which classes get instantiated and what their properties hold.

A workable chain turns deserialization into file writes, deletions or code execution, depending on what the loaded classes do in their magic methods. For Gravity Forms the fix is 3.1.3: builds <= 3.1.2 are affected, anything from 3.1.3 onward is not.

Remediation

Update to version 3.1.3, or a newer patched version

How does WordSec protect against this?

Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. Classes like this one can leave something behind, so the staged malware scanner is the second half: it looks for dropped files and modified code rather than for the request that created them. None of that substitutes for the fix: Gravity Forms 3.1.3 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Scanner
  • Login Security

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C