CVE-2023-5416

Funnelforms Free <= 3.4 - Missing Authorization to Category Deletion

2023-11-01 00:00
Alex Thomas

Strategic Overview

Status
Patched in 3.4.2
Affected Version
<= 3.4
CVSS
4.3Medium
Weakness type
CWE-862 · Missing Authorization
CVE
CVE-2023-5416
View all Funnelforms Free – Multi Step Form, Contact Form & Lead Funnel Builder vulnerabilities

At a glance

CVE-2023-5416 is a medium-severity Missing Authorization vulnerability in the Funnelforms Free WordPress plugin, affecting versions <= 3.4. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). The root cause is a missing authorization check on a reachable function. The issue is fixed in version 3.4.2; sites on affected versions should update now. Disclosed November 2023, reported by Alex Thomas.

Vulnerability Overview

The Funnelforms Free plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the fnsf_delete_category function in versions up to, and including, 3.4. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to delete categories.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.

CWE-862: Missing Authorization

Reaching this weakness in Funnelforms Free <= 3.4 takes a caller who can reach the endpoint. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.

Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For Funnelforms Free the fix is 3.4.2: builds <= 3.4 are affected, anything from 3.4.2 onward is not.

Remediation

Update to version 3.4.2, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Funnelforms Free 3.4.2 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C