Funnelforms Free <= 3.4 - Cross-Site Request Forgery to Arbitrary Post Deletion
Strategic Overview
- Status
- Patched in 3.4.2
- Affected Version
<= 3.4- CVSS
- 6.5Medium
- Weakness type
- CWE-352 · Cross-Site Request Forgery (CSRF)
- CVE
CVE-2023-5382
At a glance
CVE-2023-5382 is a medium-severity Cross-Site Request Forgery (CSRF) vulnerability in the Funnelforms Free WordPress plugin, affecting versions <= 3.4. It carries a CVSS score of 6.5 (reachable over the network; low attack complexity; high integrity impact). Exploitation requires no authentication. The issue is fixed in version 3.4.2; sites on affected versions should update now. Disclosed November 2023, reported by Duc Manh.
Vulnerability Overview
The Funnelforms Free plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.4. This is due to missing or incorrect nonce validation on the fnsf_delete_posts function. This makes it possible for unauthenticated attackers to delete arbitrary posts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site. A successful exploit has high impact on integrity.
CWE-352: Cross-Site Request Forgery (CSRF)
Reaching this weakness in Funnelforms Free <= 3.4 takes a caller who can reach the endpoint. Cross-site request forgery abuses the fact that browsers attach a victim's cookies to any request, so a state-changing action that only checks who you are, not whether you meant to act, can be triggered from another site.
An attacker who gets a logged-in user to load a crafted page can perform that action as them, with the impact scaling to whatever the victim's role is allowed to do. For Funnelforms Free the fix is 3.4.2: builds <= 3.4 are affected, anything from 3.4.2 onward is not.
Remediation
Update to version 3.4.2, or a newer patched version
How does WordSec protect against this?
The attempt arrives as an ordinary request to Funnelforms Free: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Funnelforms Free 3.4.2 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in Funnelforms Free – Multi Step Form, Contact Form & Lead Funnel Builder
- 8.8CVE-2024-10587: Funnelforms Free <= 3.7.5.1 PHP Object Injection
CVE-2024-10587 - 7.2CVE-2024-6311: Funnelforms Free <= 3.7.3.2 Arbitrary File Upload
CVE-2024-6311 - 6.5CVE-2024-6312: Funnelforms Free <= 3.7.3.2 Arbitrary File Deletion
CVE-2024-6312 - 6.5CVE-2023-5386: Funnelforms Free <= 3.4 Arbitrary Post Deletion
CVE-2023-5386 - 6.5CVE-2023-4950: Funnelforms Free <= 3.3.9 Stored Cross-Site Scripting
CVE-2023-4950 - 6.4CVE-2025-62758: Funnelforms Free <= 3.8 Stored Cross-Site Scripting
CVE-2025-62758 - 6.1CVE-2023-33999: Freemius SDK <= 2.5.9 Reflected Cross-Site Scripting
CVE-2023-33999 - 5.3CVE-2025-68582: Funnelforms Free <= 3.8 Missing Authorization
CVE-2025-68582
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C