CVE-2026-119176

CP Multi View Events Calendar <= 1.4.43 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'Subject' Parameter

2026-10-30 16:20
mrglwglwgl

Strategic Overview

Status
Patched in 1.4.44
Affected Version
<= 1.4.43
CVSS
6.4Medium
Weakness type
CWE-79 · Improper Neutralization of Input During Web Page Generation
CVE
CVE-2026-119176
View all CP Multi View Events Calendar vulnerabilities

At a glance

CVE-2026-119176 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the CP Multi View Events Calendar WordPress plugin, affecting versions <= 1.4.43. It carries a CVSS score of 6.4 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 1.4.44; sites on affected versions should update now. Disclosed October 2026, reported by mrglwglwgl.

Vulnerability Overview

The CP Multi View Events Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'Subject' parameter in all versions up to, and including, 1.4.43 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The required nonce is localized to any published page carrying the calendar shortcode, making the adddetails endpoint reachable by any authenticated user with Subscriber-level access or above.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.

CWE-79: Improper Neutralization of Input During Web Page Generation

CP Multi View Events Calendar <= 1.4.43 carries this weakness at Subject, and reaching it takes an account at Subscriber level or above. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.

Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For CP Multi View Events Calendar the fix is 1.4.44: builds <= 1.4.43 are affected, anything from 1.4.44 onward is not.

Remediation

Update to version 1.4.44, or a newer patched version

How does WordSec protect against this?

An attacker needs Subscriber access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: CP Multi View Events Calendar 1.4.44 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C