CVE-2021-24830

Advanced Access Manager <= 6.7.9 - Admin+ Stored Cross-Site Scripting

2021-10-19 00:00
Huy Nguyen

Strategic Overview

Status
Patched in 6.8.0
Affected Version
< 6.8.0
CVSS
4.8Medium
Weakness type
CWE-79 · Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE
CVE-2021-24830
View all Access Governance for WordPress (aka AAM) vulnerabilities

At a glance

CVE-2021-24830 is a medium-severity Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in the Access Governance for WordPress (aka AAM) WordPress plugin, affecting versions < 6.8.0. It carries a CVSS score of 4.8 (reachable over the network; low attack complexity). The issue is fixed in version 6.8.0; sites on affected versions should update now. Disclosed October 2021, reported by Huy Nguyen.

Vulnerability Overview

The Advanced Access Manager WordPress plugin before 6.8.0 does not escape some of its settings when outputting them, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed.

CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Reaching this weakness in Access Governance for WordPress (aka AAM) < 6.8.0 takes a caller who can reach the endpoint. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.

Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For Access Governance for WordPress (aka AAM) the fix is 6.8.0: builds < 6.8.0 are affected, anything from 6.8.0 onward is not.

Remediation

Update to version 6.8.0, or a newer patched version

How does WordSec protect against this?

The attempt arrives as an ordinary request to Access Governance for WordPress (aka AAM): WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Access Governance for WordPress (aka AAM) 6.8.0 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C