Strategic Overview
- Status
- Patched in 2.8.3
- Affected Plugin
- Access Governance for WordPress (aka AAM)
- Affected Version
< 2.8.3- CVSS
- 7.2High
- Weakness type
- CWE-22 · Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
- CVE
CVE-2014-6059
At a glance
CVE-2014-6059 is a high-severity Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in the Access Governance for WordPress (aka AAM) WordPress plugin, affecting versions < 2.8.3. It carries a CVSS score of 7.2 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). The issue is fixed in version 2.8.3; sites on affected versions should update now. Disclosed August 2014, reported by Tom Adams.
Vulnerability Overview
WordPress Advanced Access Manager Plugin before 2.8.2 has an Arbitrary File Overwrite Vulnerability
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.
CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
Reaching this weakness in Access Governance for WordPress (aka AAM) < 2.8.3 takes a caller who can reach the endpoint. Path traversal happens when user-controlled text is used to build a filesystem path without being constrained to an intended directory, so sequences like ../ walk the resolved path somewhere else.
Depending on the operation, it means reading files outside the intended folder — wp-config.php being the usual target — or writing to and deleting paths the web server can touch. For Access Governance for WordPress (aka AAM) the fix is 2.8.3: builds < 2.8.3 are affected, anything from 2.8.3 onward is not.
Remediation
Update to version 2.8.3, or a newer patched version
How does WordSec protect against this?
The attempt arrives as an ordinary request to Access Governance for WordPress (aka AAM): WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Access Governance for WordPress (aka AAM) 2.8.3 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in Access Governance for WordPress (aka AAM)
- 8.8Advanced Access Manager Unrestricted AJAX Actions
- 7.5CVE-2020-35935: Advanced Access Manager Authorization Bypass
CVE-2020-35935 - 6.4CVE-2023-51674: Advanced Access Manager <= 6.9.18 Stored XSS
CVE-2023-51674 - 6.4CVE-2023-50881: Advanced Access Manager <= 6.9.15 Stored XSS
CVE-2023-50881 - 6.1CVE-2024-29127: Advanced Access Manager <= 6.9.20 Reflected XSS
CVE-2024-29127 - 5.5CVE-2024-29124: Advanced Access Manager <= 6.9.20 Stored XSS
CVE-2024-29124 - 5.3CVE-2026-42674: Advanced Access Manager Missing Authorization
CVE-2026-42674 - 4.8CVE-2021-24830: Advanced Access Manager <= 6.7.9 Admin+ Stored XSS
CVE-2021-24830
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C