Advanced Access Manager <= 3.2.1 - Unrestricted AJAX Actions allowing Privilege Escalation
Strategic Overview
- Status
- Patched in 3.2.2
- Affected Plugin
- Access Governance for WordPress (aka AAM)
- Affected Version
< 3.2.2- CVSS
- 8.8High
- Weakness type
- CWE-285 · Improper Authorization
- CVE
CVE pending
At a glance
This record tracks a high-severity Improper Authorization vulnerability in the Access Governance for WordPress (aka AAM) WordPress plugin, affecting versions < 3.2.2. It carries a CVSS score of 8.8 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). The issue is fixed in version 3.2.2; sites on affected versions should update now. Disclosed June 2016, reported by James Golovich.
Vulnerability Overview
The Advanced Access Manager plugin for WordPress does not use capability checks on any of its registered AJAX actions. This allows authenticated attackers with any privilege level, including subscribers, to perform actions including elevating their privileges to those of an administrator.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.
CWE-285: Improper Authorization
Reaching this weakness in Access Governance for WordPress (aka AAM) < 3.2.2 takes a caller who can reach the endpoint. Improper authorization means a permission check exists but does not cover the case being exercised, so a caller who is allowed to do one thing is allowed to do a neighbouring thing as well.
A lower-privileged account performs an action reserved for a higher one, which on a multi-author or membership site means an ordinary user reaching administrative behaviour. For Access Governance for WordPress (aka AAM) the fix is 3.2.2: builds < 3.2.2 are affected, anything from 3.2.2 onward is not.
Remediation
Update to version 3.2.2, or a newer patched version
How does WordSec protect against this?
Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Access Governance for WordPress (aka AAM) 3.2.2 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Other vulnerabilities in Access Governance for WordPress (aka AAM)
- 9.8CVE-2019-25213: Advanced Access Manager <= 5.9.8.1 Arbitrary File Read
CVE-2019-25213 - 7.5CVE-2020-35935: Advanced Access Manager Authorization Bypass
CVE-2020-35935 - 7.2CVE-2014-6059: Advanced Access Manager Arbitrary File Overwrite
CVE-2014-6059 - 6.4CVE-2023-51674: Advanced Access Manager <= 6.9.18 Stored XSS
CVE-2023-51674 - 6.4CVE-2023-50881: Advanced Access Manager <= 6.9.15 Stored XSS
CVE-2023-50881 - 6.1CVE-2024-29127: Advanced Access Manager <= 6.9.20 Reflected XSS
CVE-2024-29127 - 5.5CVE-2024-29124: Advanced Access Manager <= 6.9.20 Stored XSS
CVE-2024-29124 - 5.3CVE-2026-42674: Advanced Access Manager Missing Authorization
CVE-2026-42674
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C