CVE-2026-120514

Zephyr Project Manager <= 3.3.209 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'zpm_profile_picture' Parameter

2026-11-06 21:25
zecke

Strategic Overview

Status
Patched in 3.3.210
Affected Plugin
Zephyr Project Manager
Affected Version
<= 3.3.209
CVSS
5.4Medium
Weakness type
CWE-79 · Improper Neutralization of Input During Web Page Generation
CVE
CVE-2026-120514
View all Zephyr Project Manager vulnerabilities

At a glance

CVE-2026-120514 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the Zephyr Project Manager WordPress plugin, affecting versions <= 3.3.209. It carries a CVSS score of 5.4 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 3.3.210; sites on affected versions should update now. Disclosed November 2026, reported by zecke.

Vulnerability Overview

The Zephyr Project Manager plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'zpm_profile_picture' parameter in all versions up to, and including, 3.3.209 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The injected payload is stored in the subscriber's own Zephyr profile and fires in any Administrator's browser session the first time the autocomplete mention lookup renders the avatar field, requiring no additional configuration beyond the plugin's default access_roles setting. Successful exploitation additionally requires an action by an administrator — the attacker cannot trigger the vulnerability on their own.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed.

CWE-79: Improper Neutralization of Input During Web Page Generation

Zephyr Project Manager <= 3.3.209 carries this weakness at zpm_profile_picture, and reaching it takes an account at Subscriber level or above. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.

Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For Zephyr Project Manager the fix is 3.3.210: builds <= 3.3.209 are affected, anything from 3.3.210 onward is not.

Remediation

Update to version 3.3.210, or a newer patched version

How does WordSec protect against this?

An attacker needs Subscriber access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Zephyr Project Manager 3.3.210 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C