Premium Packages – Sell Digital Products Securely < 7.3.1 - Unauthenticated Insecure Direct Object Reference
Strategic Overview
- Status
- Patched in 7.3.1
- Affected Plugin
- Premium Packages – Sell Digital Products Securely
- Affected Version
< 7.3.1- CVSS
- 5.3Medium
- Weakness type
- CWE-639 · Authorization Bypass Through User-Controlled Key
- CVE
CVE-2026-118404
At a glance
CVE-2026-118404 is a medium-severity Authorization Bypass Through User-Controlled Key vulnerability in the Premium Packages WordPress plugin, affecting versions < 7.3.1. It carries a CVSS score of 5.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 7.3.1; sites on affected versions should update now. Disclosed November 2026, reported by Ryan Fabella.
Vulnerability Overview
The Premium Packages – Sell Digital Products Securely plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to 7.3.1. This is due to missing validation on a user controlled key. This makes it possible for unauthenticated attackers to perform an unauthorized action.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.
CWE-639: Authorization Bypass Through User-Controlled Key
Reaching this weakness in Premium Packages < 7.3.1 takes no account at all. Authorization bypass through a user-controlled key, often called insecure direct object reference, means the application looks up a record by an identifier from the request without checking that the caller owns it.
Changing a number in the request is enough to read or modify other users' records, which on commerce and membership sites means customer data. For Premium Packages the fix is 7.3.1: builds < 7.3.1 are affected, anything from 7.3.1 onward is not.
Remediation
Update to version 7.3.1, or a newer patched version
How does WordSec protect against this?
This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Premium Packages 7.3.1 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in Premium Packages – Sell Digital Products Securely
- 8.8CVE-2023-4293: Premium Packages - Sell… Arbitrary User Meta Update
CVE-2023-4293 - 7.5CVE-2026-12800: Premium Packages <= 6.2.0 SQL Injection
CVE-2026-12800 - 7.5CVE-2026-61948: Premium Packages SQL Injection
CVE-2026-61948 - 7.2CVE-2026-18586: Premium Packages <= 7.0.5 Stored Cross-Site Scripting
CVE-2026-18586 - 7.2CVE-2026-93654: Premium Packages <= 7.2.1 Stored Cross-Site Scripting
CVE-2026-93654 - 7.2CVE-2026-73190: Premium Packages Stored XSS
CVE-2026-73190 - 6.5CVE-2026-15906: Premium Packages <= 7.0.4 SQL Injection
CVE-2026-15906 - 6.4CVE-2026-110664: Premium Packages <= 7.2.8 Stored Cross-Site Scripting
CVE-2026-110664
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C