CVE-2026-110983

Photo Album Plus <= 9.3.04.3 - Cross-Site Request Forgery

2026-10-27 00:00
Karthik Ramakrishnan

Strategic Overview

Status
Patched in 9.3.04.004
Affected Plugin
WP Photo Album Plus
Affected Version
<= 9.3.04.3
CVSS
4.3Medium
Weakness type
CWE-352 · Cross-Site Request Forgery
CVE
CVE-2026-110983
View all WP Photo Album Plus vulnerabilities

At a glance

CVE-2026-110983 is a medium-severity Cross-Site Request Forgery vulnerability in the WP Photo Album Plus WordPress plugin, affecting versions <= 9.3.04.3. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 9.3.04.004; sites on affected versions should update now. Disclosed October 2026, reported by Karthik Ramakrishnan.

Vulnerability Overview

The Photo Album Plus plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 9.3.04.3. This is due to missing or incorrect nonce validation on a function. This makes it possible for unauthenticated attackers to perform an unauthorized action via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site.

CWE-352: Cross-Site Request Forgery

Reaching this weakness in WP Photo Album Plus <= 9.3.04.3 takes a caller who can reach the endpoint. Cross-site request forgery abuses the fact that browsers attach a victim's cookies to any request, so a state-changing action that only checks who you are, not whether you meant to act, can be triggered from another site.

An attacker who gets a logged-in user to load a crafted page can perform that action as them, with the impact scaling to whatever the victim's role is allowed to do. For WP Photo Album Plus the fix is 9.3.04.004: builds <= 9.3.04.3 are affected, anything from 9.3.04.004 onward is not.

Remediation

Update to version 9.3.04.004, or a newer patched version

How does WordSec protect against this?

The attempt arrives as an ordinary request to WP Photo Album Plus: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: WP Photo Album Plus 9.3.04.004 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C