Discussion Board <= 2.6.0 - Authenticated (Subscriber+) Stored Cross-Site Scripting via User Profile Website (user_url) Field
Strategic Overview
- Status
- Patched in 2.6.1
- Affected Plugin
- Discussion Board – WordPress Forum Plugin
- Affected Version
<= 2.6.0- CVSS
- 6.4Medium
- Weakness type
- CWE-79 · Improper Neutralization of Input During Web Page Generation
- CVE
CVE-2026-107765
At a glance
CVE-2026-107765 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the Discussion Board WordPress plugin, affecting versions <= 2.6.0. It carries a CVSS score of 6.4 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 2.6.1; sites on affected versions should update now. Disclosed October 2026, reported by Adrien Brunner.
Vulnerability Overview
The Discussion Board – WordPress Forum Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 2.6.0 via the user profile Website (user_url) field. This is due to insufficient output escaping in the ctdb_filter_comment_author_name() callback hooked to get_comment_author_link, which interpolates the raw user_url value into a single-quoted href attribute without esc_url() or esc_attr(). This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses a Discussion Board topic containing the attacker's reply.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-79: Improper Neutralization of Input During Web Page Generation
Discussion Board <= 2.6.0 carries this weakness at ctdb_filter_comment_author_name(), and reaching it takes an account at Subscriber level or above. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.
Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For Discussion Board the fix is 2.6.1: builds <= 2.6.0 are affected, anything from 2.6.1 onward is not.
Remediation
Update to version 2.6.1, or a newer patched version
How does WordSec protect against this?
An attacker needs Subscriber access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Discussion Board 2.6.1 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Other vulnerabilities in Discussion Board – WordPress Forum Plugin
- 6.3CVE-2025-8483: Discussion Board Arbitrary Shortcode Execution
CVE-2025-8483 - 5.4CVE-2023-39161: Discussion Board <= 2.4.8 Content Injection
CVE-2023-39161 - 5.3CVE-2026-115958: Discussion Board Missing Authorization
CVE-2026-115958 - 4.3CVE-2025-69023: Discussion Board <= 2.5.7 Missing Authorization
CVE-2025-69023
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C