WP Data Access <= 5.5.90 - Authenticated (Subscriber+) SQL Injection via 'engine' Parameter
Strategic Overview
- Status
- Patched in 5.5.91
- Affected Version
<= 5.5.90- CVSS
- 5.3Medium
- Weakness type
- CWE-89 · Improper Neutralization of Special Elements used in an SQL Command
- CVE
CVE-2026-121536
At a glance
CVE-2026-121536 is a medium-severity Improper Neutralization of Special Elements used in an SQL Command vulnerability in the WP Data Access WordPress plugin, affecting versions <= 5.5.90. It carries a CVSS score of 5.3 (reachable over the network; high confidentiality impact). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 5.5.91; sites on affected versions should update now. Disclosed November 2026, reported by Daniel test.
Vulnerability Overview
The WP Data Access – App Builder for Tables, Forms, Dashboards, Charts & Maps plugin for WordPress is vulnerable to generic SQL Injection via the 'engine' parameter in all versions up to, and including, 5.5.90 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. This is only exploitable when an administrator has configured a Data Project page to admit a lower-privileged role, which is the plugin's documented mechanism for sharing projects with subscribers and other users.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, and no interaction from a victim user. A successful exploit has high impact on confidentiality.
CWE-89: Improper Neutralization of Special Elements used in an SQL Command
WP Data Access <= 5.5.90 carries this weakness at engine, and reaching it takes an account at Subscriber level or above. SQL injection happens when request data is concatenated into a query instead of being bound as a parameter, letting an attacker change the structure of the statement rather than just its values.
A working injection can read any table the database user can see, which on a WordPress install means user records, password hashes and session or API secrets stored in options. For WP Data Access the fix is 5.5.91: builds <= 5.5.90 are affected, anything from 5.5.91 onward is not.
Remediation
Update to version 5.5.91, or a newer patched version
How does WordSec protect against this?
An attacker needs Subscriber access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: WP Data Access 5.5.91 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in WP Data Access – App Builder for Tables, Forms, Dashboards, Charts & Maps
- 7.5CVE-2024-12428: WP Data Access SQL Injection
CVE-2024-12428 - 7.5CVE-2023-1874: WP Data Access <= 5.3.7 Privilege Escalation
CVE-2023-1874 - 7.2CVE-2026-66663: WP Data Access Stored XSS
CVE-2026-66663 - 7.2CVE-2021-24866: WP Data Access <= 4.3.1 Admin+ SQL Injection
CVE-2021-24866 - 6.4CVE-2026-118204: WP Data Access <= 5.5.89 Stored Cross-Site Scripting
CVE-2026-118204 - 6.4CVE-2026-120479: WP Data Access <= 5.5.90 Stored Cross-Site Scripting
CVE-2026-120479 - 6.4CVE-2026-118048: WP Data Access <= 5.5.89 Stored Cross-Site Scripting
CVE-2026-118048 - 6.4CVE-2026-106470: Data Access <= 5.5.87 Server-Side Request Forgery
CVE-2026-106470
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C