WP Data Access <= 5.5.89 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'Image URL' Media-Type Column Renderer
Strategic Overview
- Status
- Patched in 5.5.90
- Affected Version
<= 5.5.89- CVSS
- 6.4Medium
- Weakness type
- CWE-79 · Improper Neutralization of Input During Web Page Generation
- CVE
CVE-2026-118204
At a glance
CVE-2026-118204 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the WP Data Access WordPress plugin, affecting versions <= 5.5.89. It carries a CVSS score of 6.4 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 5.5.90; sites on affected versions should update now. Disclosed November 2026, reported by Shinya Murakami (4n86rakam1).
Vulnerability Overview
The WP Data Access – App Builder for Tables, Forms, Dashboards, Charts & Maps plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'ImageURL column value (populated from wp_usermeta.description in the demonstrated path)' parameter in all versions up to, and including, 5.5.89 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires an administrator to have published a DataTables shortcode over a database column the attacker controls (e.g., wp_usermeta.description) with the Image URL media type assigned to that column — both are supported plugin features but are not enabled by default.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-79: Improper Neutralization of Input During Web Page Generation
Reaching this weakness in WP Data Access <= 5.5.89 takes an account at Subscriber level or above. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.
Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For WP Data Access the fix is 5.5.90: builds <= 5.5.89 are affected, anything from 5.5.90 onward is not.
Remediation
Update to version 5.5.90, or a newer patched version
How does WordSec protect against this?
An attacker needs Subscriber access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: WP Data Access 5.5.90 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in WP Data Access – App Builder for Tables, Forms, Dashboards, Charts & Maps
- 7.5CVE-2026-95605: WP Data Access SQL Injection
CVE-2026-95605 - 7.5CVE-2026-93621: WP Data Access SQL Injection
CVE-2026-93621 - 7.5CVE-2026-81293: WP Data Access SQL Injection
CVE-2026-81293 - 7.5CVE-2026-42665: WP Data Access SQL Injection
CVE-2026-42665 - 7.5CVE-2024-12428: WP Data Access SQL Injection
CVE-2024-12428 - 7.5CVE-2023-1874: WP Data Access <= 5.3.7 Privilege Escalation
CVE-2023-1874 - 7.2CVE-2021-24866: WP Data Access <= 4.3.1 Admin+ SQL Injection
CVE-2021-24866 - 6.4CVE-2026-106470: Data Access <= 5.5.87 Server-Side Request Forgery
CVE-2026-106470
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C