CVE-2026-15372

2FA <= 4.0.0 - Two-Factor Authentication Bypass

2026-07-29 00:00
Jakub Herman

Strategic Overview

Status
Patched in 4.1.0
Affected Version
<= 4.0.0
CVSS
4.3Medium
Weakness type
CWE-693 · Protection Mechanism Failure
CVE
CVE-2026-15372
View all WP 2FA – Two-factor authentication for WordPress vulnerabilities

At a glance

CVE-2026-15372 is a medium-severity Protection Mechanism Failure vulnerability in the WP 2FA WordPress plugin, affecting versions <= 4.0.0. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). The issue is fixed in version 4.1.0; sites on affected versions should update now. Disclosed July 2026, reported by Jakub Herman.

Vulnerability Overview

The WP 2FA – Two-factor authentication for WordPress plugin for WordPress is vulnerable to Two-Factor Authentication Bypass in all versions up to, and including, 4.0.0. This makes it possible for authenticated attackers, with Custom-level access and above, to bypass 2FA.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.

CWE-693: Protection Mechanism Failure

The product does not use or incorrectly uses a protection mechanism that provides sufficient defense against directed attacks against the product.

Remediation

Update to version 4.1.0, or a newer patched version

How does WordSec protect against this?

The fix is the thing that ends this: WP 2FA 4.1.0 closes this, and updating the plugin is the step that ends it.

  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C