Uncanny Toolkit for LearnDash <= 3.8.2 - Unauthenticated Authentication Bypass via 'email' Parameter
Strategic Overview
- Status
- Patched in 3.8.3
- Affected Plugin
- Uncanny Toolkit for LearnDash
- Affected Version
<= 3.8.2- CVSS
- 9.8Critical
- Weakness type
- CWE-287 · Improper Authentication
- CVE
CVE-2026-119096
At a glance
CVE-2026-119096 is a critical-severity Improper Authentication vulnerability in the Uncanny Toolkit for LearnDash WordPress plugin, affecting versions <= 3.8.2. It carries a CVSS score of 9.8 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). Exploitation requires no authentication. The issue is fixed in version 3.8.3; sites on affected versions should update now. Disclosed October 2026, reported by Kuba.
Vulnerability Overview
The Uncanny Toolkit for LearnDash plugin for WordPress is vulnerable to Authentication Bypass in versions up to, and including, 3.8.2 via the `email` parameter of the `uo_login_action()` function. This is due to a parser-differential flaw in which the plugin's account-verification gate resolves the submitted `email` value using the raw, unsanitized string passed to `get_user_by()`, while the subsequent `wp_signon()` call relies on WordPress core's internal `sanitize_user()` to strip appended junk characters — causing the gate lookup to fail and be skipped entirely while the real account is still resolved and authenticated. This makes it possible for unauthenticated attackers to log in to unverified or administrator-suspended accounts whose credentials they already possess, obtaining a valid `wordpress_logged_in` session cookie and defeating the plugin's account-approval and account-suspension controls. The nonce required to reach the handler is freely obtainable in the same request from the unauthenticated `ult-refresh-nonce` endpoint, making exploitation trivial for any attacker with network access to the site and knowledge of a target account's credentials.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.
CWE-287: Improper Authentication
Uncanny Toolkit for LearnDash <= 3.8.2 carries this weakness at uo_login_action(), and reaching it takes no account at all. Improper authentication means the mechanism that proves who a caller is can be satisfied without the secret it was supposed to require.
An attacker authenticates as another user — administrators included — without ever knowing a password, so password policies and login rate limits never come into play. For Uncanny Toolkit for LearnDash the fix is 3.8.3: builds <= 3.8.2 are affected, anything from 3.8.3 onward is not.
Remediation
Update to version 3.8.3, or a newer patched version
How does WordSec protect against this?
This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Uncanny Toolkit for LearnDash 3.8.3 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Other vulnerabilities in Uncanny Toolkit for LearnDash
- 8.8CVE-2026-107127: Uncanny Toolkit for LearnDash < 3.8.2 CSRF
CVE-2026-107127 - 8.8CVE-2023-23714: Uncanny Toolkit for LearnDash CSRF
CVE-2023-23714 - 8.8Uncanny Toolkit for LearnDash <= 3.6.3 Cross-Site Request Forgery
- 6.5CVE-2023-34019: Uncanny Toolkit for LearnDash Missing Authorization
CVE-2023-34019 - 6.4CVE-2025-57988: Uncanny Toolkit for LearnDash <= 3.7.0.3 Stored XSS
CVE-2025-57988 - 6.4CVE-2025-48080: Uncanny Toolkit for LearnDash <= 3.7.0.2 Stored XSS
CVE-2025-48080 - 6.4CVE-2025-22268: Uncanny Toolkit for LearnDash <= 3.7.0.1 Stored XSS
CVE-2025-22268 - 4.3CVE-2023-34020: Uncanny Toolkit for LearnDash <= 3.6.4.3 Open Redirect
CVE-2023-34020
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C