Uncanny Toolkit for LearnDash < 3.8.2 - Cross-Site Request Forgery
Strategic Overview
- Status
- Patched in 3.8.2
- Affected Plugin
- Uncanny Toolkit for LearnDash
- Affected Version
< 3.8.2- CVSS
- 8.8High
- Weakness type
- CWE-352 · Cross-Site Request Forgery (CSRF)
- CVE
CVE-2026-107127
At a glance
CVE-2026-107127 is a high-severity Cross-Site Request Forgery (CSRF) vulnerability in the Uncanny Toolkit for LearnDash WordPress plugin, affecting versions < 3.8.2. It carries a CVSS score of 8.8 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). Exploitation requires no authentication. The issue is fixed in version 3.8.2; sites on affected versions should update now. Disclosed October 2026, reported by Ryan Fabella.
Vulnerability Overview
The Uncanny Toolkit for LearnDash plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to 3.8.2. This is due to missing or incorrect nonce validation on a function. This makes it possible for unauthenticated attackers to takeover other user's accounts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.
CWE-352: Cross-Site Request Forgery (CSRF)
Reaching this weakness in Uncanny Toolkit for LearnDash < 3.8.2 takes a caller who can reach the endpoint. Cross-site request forgery abuses the fact that browsers attach a victim's cookies to any request, so a state-changing action that only checks who you are, not whether you meant to act, can be triggered from another site.
An attacker who gets a logged-in user to load a crafted page can perform that action as them, with the impact scaling to whatever the victim's role is allowed to do. For Uncanny Toolkit for LearnDash the fix is 3.8.2: builds < 3.8.2 are affected, anything from 3.8.2 onward is not.
Remediation
Update to version 3.8.2, or a newer patched version
How does WordSec protect against this?
The attempt arrives as an ordinary request to Uncanny Toolkit for LearnDash: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Uncanny Toolkit for LearnDash 3.8.2 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in Uncanny Toolkit for LearnDash
- 6.5CVE-2023-34019: Uncanny Toolkit for LearnDash Missing Authorization
CVE-2023-34019 - 6.4CVE-2025-57988: Uncanny Toolkit for LearnDash <= 3.7.0.3 Stored XSS
CVE-2025-57988 - 6.4CVE-2025-48080: Uncanny Toolkit for LearnDash <= 3.7.0.2 Stored XSS
CVE-2025-48080 - 6.4CVE-2025-22268: Uncanny Toolkit for LearnDash <= 3.7.0.1 Stored XSS
CVE-2025-22268 - 4.3CVE-2023-34020: Uncanny Toolkit for LearnDash <= 3.6.4.3 Open Redirect
CVE-2023-34020 - 2.7CVE-2026-107128: Uncanny Toolkit for LearnDash Missing Authorization
CVE-2026-107128
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C