Spectra Legacy – Gutenberg Blocks <= 2.20.0 - Authenticated (Contributor+) Sensitive Information Exposure
Strategic Overview
- Status
- Patched in 2.20.1
- Affected Plugin
- Spectra Legacy – Gutenberg Blocks
- Affected Version
<= 2.20.0- CVSS
- 4.3Medium
- Weakness type
- CWE-200 · Exposure of Sensitive Information to an Unauthorized Actor
- CVE
CVE-2026-16302
At a glance
CVE-2026-16302 is a medium-severity Exposure of Sensitive Information to an Unauthorized Actor vulnerability in the Spectra Legacy WordPress plugin, affecting versions <= 2.20.0. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Contributor level or above. The issue is fixed in version 2.20.1; sites on affected versions should update now. Disclosed September 2026, reported by se1en.
Vulnerability Overview
The Spectra Legacy – Gutenberg Blocks plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.20.0 via the editor_assets function, which exposes the uag_insta_linked_accounts option through the uagb_blocks_info object without a capability check. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract sensitive data including raw Instagram Graph API access tokens configured by an administrator. Exploitation requires the Spectra Pro plugin to be active with a linked Instagram account.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
Reaching this weakness in Spectra Legacy <= 2.20.0 takes an account at Contributor level or above. Sensitive information exposure means data the application intended to keep internal is returned to a caller who should not be able to see it.
The disclosed data — credentials, tokens, customer records or internal paths — is usually worth more as material for a follow-up attack than as an end in itself. For Spectra Legacy the fix is 2.20.1: builds <= 2.20.0 are affected, anything from 2.20.1 onward is not.
Remediation
Update to version 2.20.1, or a newer patched version
How does WordSec protect against this?
The fix is the thing that ends this: Spectra Legacy 2.20.1 closes this, and updating the plugin is the step that ends it.
- Alerts
External References
Related records
Other vulnerabilities in Spectra Legacy – Gutenberg Blocks
- 8.8CVE-2026-7465: Spectra Gutenberg Blocks <= 2.19.25 RCE
CVE-2026-7465 - 8.5CVE-2023-36679: Spectra <= 2.6.6 SSRF in import_wpforms
CVE-2023-36679 - 6.5CVE-2026-92294: Spectra Gutenberg Blocks Unauthenticated Limited
CVE-2026-92294 - 6.5CVE-2023-23735: Spectra HTML Injection in Emails
CVE-2023-23735 - 6.4CVE-2026-12900: Spectra Gutenberg Blocks <= 2.19.28 Stored XSS
CVE-2026-12900 - 6.4CVE-2025-11162: Spectra <= 2.19.14 Stored Cross-Site Scripting
CVE-2025-11162 - 6.4CVE-2025-1784: Spectra – WordPress Gutenberg Blocks Stored XSS
CVE-2025-1784 - 6.4CVE-2024-10484: Spectra – WordPress Gutenberg Blocks Stored XSS
CVE-2024-10484
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C