Spectra Gutenberg Blocks <= 2.20.4 - Missing Authorization to Unauthenticated Limited Theme File Deletion and Modification via 'page', 'path', and 'settings' GET Parameters
Strategic Overview
- Status
- Patched in 2.20.5
- Affected Plugin
- Spectra Legacy – Gutenberg Blocks
- Affected Version
<= 2.20.4- CVSS
- 6.5Medium
- Weakness type
- CWE-862 · Missing Authorization
- CVE
CVE-2026-92294
At a glance
CVE-2026-92294 is a medium-severity Missing Authorization vulnerability in the Spectra Legacy WordPress plugin, affecting versions <= 2.20.4. It carries a CVSS score of 6.5 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 2.20.5; sites on affected versions should update now. Disclosed October 2026, reported by AlexHenry.
Vulnerability Overview
The Spectra Gutenberg Blocks – Website Builder for the Block Editor plugin for WordPress is vulnerable to limited file deletion due to insufficient file path validation in the '__construct' function in all versions up to, and including, 2.20.4 This makes it possible for unauthenticated attackers to delete theme files on the server.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.
CWE-862: Missing Authorization
Spectra Legacy <= 2.20.4 carries this weakness at __construct, and reaching it takes no account at all. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.
Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For Spectra Legacy the fix is 2.20.5: builds <= 2.20.4 are affected, anything from 2.20.5 onward is not.
Remediation
Update to version 2.20.5, or a newer patched version
How does WordSec protect against this?
This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Spectra Legacy 2.20.5 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in Spectra Legacy – Gutenberg Blocks
- 8.8CVE-2026-7465: Spectra Gutenberg Blocks <= 2.19.25 RCE
CVE-2026-7465 - 8.5CVE-2023-36679: Spectra <= 2.6.6 SSRF in import_wpforms
CVE-2023-36679 - 6.5CVE-2023-23735: Spectra HTML Injection in Emails
CVE-2023-23735 - 6.4CVE-2026-12900: Spectra Gutenberg Blocks <= 2.19.28 Stored XSS
CVE-2026-12900 - 6.4CVE-2025-11162: Spectra <= 2.19.14 Stored Cross-Site Scripting
CVE-2025-11162 - 6.4CVE-2025-1784: Spectra – WordPress Gutenberg Blocks Stored XSS
CVE-2025-1784 - 6.4CVE-2024-10484: Spectra – WordPress Gutenberg Blocks Stored XSS
CVE-2024-10484 - 6.4CVE-2024-7590: Spectra – WordPress Gutenberg Blocks Stored XSS
CVE-2024-7590
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C