SureCart – Ecommerce Made Easy For Selling Physical Products, Digital Downloads, Subscriptions, Donations, & Payments <= 4.9.5 - Unauthenticated Account Takeover
Strategic Overview
- Status
- Patched in 4.9.6
- Affected Plugin
- SureCart – Ecommerce Made Easy For Selling Physical Products, Digital Downloads, Subscriptions, Donations, & Payments
- Affected Version
<= 4.9.5- CVSS
- 8.1High
- Weakness type
- CWE-287 · Improper Authentication
- CVE
CVE pending
At a glance
This record tracks a high-severity Improper Authentication vulnerability in the SureCart WordPress plugin, affecting versions <= 4.9.5. It carries a CVSS score of 8.1 (reachable over the network; high confidentiality, integrity, availability impact). Exploitation requires no authentication. The issue is fixed in version 4.9.6; sites on affected versions should update now. Disclosed October 2026, reported by hamachi_jp.
Vulnerability Overview
The SureCart plugin for WordPress is vulnerable to unauthenticated account takeover in all versions up to, and including, 4.9.5. The passwordless one-time-code login REST route (VerificationCodeController::verify(), whose permission callback returns true) resolves an attacker-supplied login to any WordPress user, verifies a 6-digit code, and on success calls $user->login() → wp_set_auth_cookie() for a user of any role. In the affected versions this path has no per-account attempt counter, no persistent email/IP lockout or rate limit (the upstream CDN throttle is bypassable via IP rotation), and no restriction preventing high-privilege accounts from being logged in through it. An unauthenticated attacker can trigger a code for any user (including an administrator) via the companion unauthenticated endpoint and brute-force the 6-digit code to obtain an authenticated session as that user, resulting in a full administrator account takeover.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, and no privileges on the target site, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.
CWE-287: Improper Authentication
SureCart <= 4.9.5 carries this weakness at verify(), and reaching it takes no account at all. Improper authentication means the mechanism that proves who a caller is can be satisfied without the secret it was supposed to require.
An attacker authenticates as another user — administrators included — without ever knowing a password, so password policies and login rate limits never come into play. For SureCart the fix is 4.9.6: builds <= 4.9.5 are affected, anything from 4.9.6 onward is not.
Remediation
Update to version 4.9.6, or a newer patched version
How does WordSec protect against this?
This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: SureCart 4.9.6 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in SureCart – Ecommerce Made Easy For Selling Physical Products, Digital Downloads, Subscriptions, Donations, & Payments
- 8.8CVE-2026-18480: SureCart Arbitrary Account Email Takeover
CVE-2026-18480 - 8.1CVE-2026-7655: SureCart <= 4.2.3 Linked WordPress Account Takeover
CVE-2026-7655 - 7.5CVE-2026-106599: SureCart PHP Object Injection
CVE-2026-106599 - 7.2CVE-2026-107653: SureCart <= 4.9.4 Stored Cross-Site Scripting
CVE-2026-107653 - 7.2CVE-2026-112221: SureCart Stored XSS
CVE-2026-112221 - 7.2CVE-2026-109224: SureCart <= 4.9.4 Stored Cross-Site Scripting
CVE-2026-109224 - 7.2CVE-2026-105874: SureCart Stored XSS
CVE-2026-105874 - 6.4CVE-2026-112840: SureCart Stored XSS
CVE-2026-112840
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C