SureCart – Ecommerce Made Easy For Selling Physical Products, Digital Downloads, Subscriptions, Donations, & Payments <= 4.9.5 - Missing Authorization
Strategic Overview
- Status
- Patched in 4.9.6
- Affected Plugin
- SureCart – Ecommerce Made Easy For Selling Physical Products, Digital Downloads, Subscriptions, Donations, & Payments
- Affected Version
<= 4.9.5- CVSS
- 5.3Medium
- Weakness type
- CWE-287 · Improper Authentication
- CVE
CVE-2026-112241
At a glance
CVE-2026-112241 is a medium-severity Improper Authentication vulnerability in the SureCart WordPress plugin, affecting versions <= 4.9.5. It carries a CVSS score of 5.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 4.9.6; sites on affected versions should update now. Disclosed October 2026, reported by Deva Parekh.
Vulnerability Overview
The SureCart – Ecommerce Made Easy For Selling Physical Products, Digital Downloads, Subscriptions, Donations, & Payments plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on a function in all versions up to, and including, 4.9.5. This makes it possible for unauthenticated attackers to perform an unauthorized action.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.
CWE-287: Improper Authentication
Reaching this weakness in SureCart <= 4.9.5 takes a caller who can reach the endpoint. Improper authentication means the mechanism that proves who a caller is can be satisfied without the secret it was supposed to require.
An attacker authenticates as another user — administrators included — without ever knowing a password, so password policies and login rate limits never come into play. For SureCart the fix is 4.9.6: builds <= 4.9.5 are affected, anything from 4.9.6 onward is not.
Remediation
Update to version 4.9.6, or a newer patched version
How does WordSec protect against this?
Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: SureCart 4.9.6 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Other vulnerabilities in SureCart – Ecommerce Made Easy For Selling Physical Products, Digital Downloads, Subscriptions, Donations, & Payments
- 8.8CVE-2026-18480: SureCart Arbitrary Account Email Takeover
CVE-2026-18480 - 8.1CVE-2026-7655: SureCart <= 4.2.3 Linked WordPress Account Takeover
CVE-2026-7655 - 7.5CVE-2026-106599: SureCart PHP Object Injection
CVE-2026-106599 - 7.2CVE-2026-112221: SureCart Stored XSS
CVE-2026-112221 - 7.2CVE-2026-109224: SureCart <= 4.9.4 Stored Cross-Site Scripting
CVE-2026-109224 - 7.2CVE-2026-105874: SureCart Stored XSS
CVE-2026-105874 - 6.4CVE-2026-112840: SureCart Stored XSS
CVE-2026-112840 - 6.4CVE-2026-109697: SureCart Stored XSS
CVE-2026-109697
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C