ShopEngine <= 4.8.5 - Cross-Site Request Forgery to Wishlist Manipulation
Strategic Overview
- Status
- Patched in 4.8.6
- Affected Plugin
- ShopEngine – All-in-One Elementor WooCommerce Builder with eCommerce Templates & Woo Widgets
- Affected Version
<= 4.8.5- CVSS
- 4.3Medium
- Weakness type
- CWE-352 · Cross-Site Request Forgery (CSRF)
- CVE
CVE-2025-12358
At a glance
CVE-2025-12358 is a medium-severity Cross-Site Request Forgery (CSRF) vulnerability in the ShopEngine WordPress plugin, affecting versions <= 4.8.5. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 4.8.6; sites on affected versions should update now. Disclosed December 2025, reported by Adrian Lukita.
Vulnerability Overview
The ShopEngine Elementor WooCommerce Builder Addon plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.8.5. This is due to missing nonce validation on the "post_add_to_list" function as well as an incorrect permissions callback in the "Api/init" function. This makes it possible for unauthenticated attackers to add or remove products from a user's wishlist via a forged request granted they can trick a site's user into performing an action such as clicking on a link.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site.
CWE-352: Cross-Site Request Forgery (CSRF)
ShopEngine <= 4.8.5 carries this weakness at post_add_to_list, and reaching it takes a caller who can reach the endpoint. Cross-site request forgery abuses the fact that browsers attach a victim's cookies to any request, so a state-changing action that only checks who you are, not whether you meant to act, can be triggered from another site.
An attacker who gets a logged-in user to load a crafted page can perform that action as them, with the impact scaling to whatever the victim's role is allowed to do. For ShopEngine the fix is 4.8.6: builds <= 4.8.5 are affected, anything from 4.8.6 onward is not.
Remediation
Update to version 4.8.6, or a newer patched version
How does WordSec protect against this?
The attempt arrives as an ordinary request to ShopEngine: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: ShopEngine 4.8.6 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in ShopEngine – All-in-One Elementor WooCommerce Builder with eCommerce Templates & Woo Widgets
- 7.2CVE-2026-75971: ShopEngine Elementor… Privilege Escalation
CVE-2026-75971 - 6.4CVE-2026-85575: The ShopEngine Elementor WooCommerce… Stored XSS
CVE-2026-85575 - 2.7CVE-2025-11888: ShopEngine Elementor… Incorrect Authorization
CVE-2025-11888 - 2.7CVE-2025-10173: ShopEngine Elementor… Insufficient Authorization
CVE-2025-10173
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C