CVE-2022-45371

ShopEngine <= 4.1.1 - Cross-Site Request Forgery via get_product

2023-04-19 00:00
Muhammad Daffa

Strategic Overview

At a glance

CVE-2022-45371 is a medium-severity Cross-Site Request Forgery (CSRF) vulnerability in the ShopEngine WordPress plugin, affecting versions <= 4.1.1. It carries a CVSS score of 5.4 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 4.1.2; sites on affected versions should update now. Disclosed April 2023, reported by Muhammad Daffa.

Vulnerability Overview

The ShopEngine plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 4.1.1. This is due to missing or incorrect nonce validation on the get_product function. This makes it possible for unauthenticated attackers to update product IDs via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site.

CWE-352: Cross-Site Request Forgery (CSRF)

Reaching this weakness in ShopEngine <= 4.1.1 takes a caller who can reach the endpoint. Cross-site request forgery abuses the fact that browsers attach a victim's cookies to any request, so a state-changing action that only checks who you are, not whether you meant to act, can be triggered from another site.

An attacker who gets a logged-in user to load a crafted page can perform that action as them, with the impact scaling to whatever the victim's role is allowed to do. For ShopEngine the fix is 4.1.2: builds <= 4.1.1 are affected, anything from 4.1.2 onward is not.

Remediation

Update to version 4.1.2, or a newer patched version

How does WordSec protect against this?

The attempt arrives as an ordinary request to ShopEngine: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: ShopEngine 4.1.2 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C