Security Optimizer <= 1.6.8 - Two-Factor Authentication via Brute Force
Strategic Overview
- Status
- Patched in 1.6.9
- Affected Plugin
- Security Optimizer – The All-In-One Protection Plugin
- Affected Version
<= 1.6.8- CVSS
- 4.3Medium
- Weakness type
- CWE-307 · Improper Restriction of Excessive Authentication Attempts
- CVE
CVE-2026-118185
At a glance
CVE-2026-118185 is a medium-severity Improper Restriction of Excessive Authentication Attempts vulnerability in the Security Optimizer WordPress plugin, affecting versions <= 1.6.8. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). The issue is fixed in version 1.6.9; sites on affected versions should update now. Disclosed October 2026, reported by Karthik Ramakrishnan.
Vulnerability Overview
The Security Optimizer plugin for WordPress is vulnerable to Two-Factor Authentication Bypass in all versions up to, and including, 1.6.8. This is due to missing rate-limiting on 2FA code submission endpoints, allowing unlimited guesses without triggering the existing login-attempt throttle. This makes it possible for unauthenticated attackers to brute-force the two-factor authentication code submitted during a pending login challenge and gain unauthorized access to accounts. Two-factor authentication must be enabled for the target user role in the plugin settings, and the attacker must already know the target user's password.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-307: Improper Restriction of Excessive Authentication Attempts
The product does not implement sufficient measures to prevent multiple failed authentication attempts within a short time frame.
Remediation
Update to version 1.6.9, or a newer patched version
How does WordSec protect against this?
The fix is the thing that ends this: Security Optimizer 1.6.9 closes this, and updating the plugin is the step that ends it.
- Alerts
External References
Related records
Other vulnerabilities in Security Optimizer – The All-In-One Protection Plugin
- 9.8CVE-2022-0992: SiteGround Security <= 1.2.5 Authentication Bypass
CVE-2022-0992 - 8.1CVE-2022-0993: SiteGround Security Authorization Weakness
CVE-2022-0993 - 7.2CVE-2023-0234: SiteGround Security <= 1.3.0 SQL Injection
CVE-2023-0234 - 5.3CVE-2026-82228: Security Optimizer 2-Factor Authentication Bypass
CVE-2026-82228 - 5.3CVE-2026-13342: Security Optimizer IP Allowlist Bypass
CVE-2026-13342 - 5.3CVE-2025-66121: SiteGround Security <= 1.5.8 Missing Authorization
CVE-2025-66121 - 4.3CVE-2024-38774: Security Optimizer Missing Authorization
CVE-2024-38774
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C