CVE-2026-112328

Sensei LMS – Online Courses, Quizzes, & Learning <= 4.26.3 - Missing Authorization

2026-10-19 00:00
Ikram-4

Strategic Overview

Status
Patched in 4.26.4
Affected Version
<= 4.26.3
CVSS
4.3Medium
Weakness type
CWE-862 · Missing Authorization
CVE
CVE-2026-112328
View all Sensei LMS – Online Courses, Quizzes, & Learning vulnerabilities

At a glance

CVE-2026-112328 is a medium-severity Missing Authorization vulnerability in the Sensei LMS WordPress plugin, affecting versions <= 4.26.3. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). The root cause is a missing authorization check on a reachable function. The issue is fixed in version 4.26.4; sites on affected versions should update now. Disclosed October 2026, reported by Ikram-4.

Vulnerability Overview

The Sensei LMS – Online Courses, Quizzes, & Learning plugin for WordPress is vulnerable to unauthorized access in all versions up to, and including, 4.26.3. This is due to a missing capability check on a function. This makes it possible for authenticated attackers to perform an unauthorized action.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.

CWE-862: Missing Authorization

Reaching this weakness in Sensei LMS <= 4.26.3 takes a caller who can reach the endpoint. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.

Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For Sensei LMS the fix is 4.26.4: builds <= 4.26.3 are affected, anything from 4.26.4 onward is not.

Remediation

Update to version 4.26.4, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Sensei LMS 4.26.4 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C