CVE-2026-89050

Quads Ads Manager for Google AdSense 3.0.4 - Authenticated (Subscriber+) Payment Bypass to Unpaid Ad Placement Acquisition

2026-09-11 00:00
JunHee CHO

Strategic Overview

Status
Patched in 3.0.5
Affected Version
3.0.4
CVSS
4.3Medium
Weakness type
CWE-602 · Client-Side Enforcement of Server-Side Security
CVE
CVE-2026-89050
View all Quads Ads Manager for Google AdSense vulnerabilities

At a glance

CVE-2026-89050 is a medium-severity Client-Side Enforcement of Server-Side Security vulnerability in the Quads Ads Manager for Google AdSense WordPress plugin, affecting versions 3.0.4. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 3.0.5; sites on affected versions should update now. Disclosed September 2026, reported by JunHee CHO.

Vulnerability Overview

The Quads Ads Manager for Google AdSense plugin for WordPress is vulnerable to Payment Bypass in all versions up to 3.0.4. This is due to missing server-side payment verification with the configured payment gateway before marking an order as paid. This makes it possible for authenticated attackers, with subscriber-level access and above, to obtain a paid ad placement without completing payment by triggering the order completion flow without a verified gateway transaction.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.

CWE-602: Client-Side Enforcement of Server-Side Security

The product includes a server that relies on the client to implement a protection mechanism that is intended to protect the server.

Remediation

Update to version 3.0.5, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Quads Ads Manager for Google AdSense 3.0.5 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C