CVE-2025-10268

Printcart Web to Print Product Designer for WooCommerce <= 2.5.1 - Directory Traversal to Unauthenticated Folder Content Disclosure

2026-06-04 00:00
D01EXPLOIT OFFICIAL

Strategic Overview

Status
Patched in 2.5.2
Affected Version
<= 2.5.1
CVSS
5.3Medium
Weakness type
CWE-22 · Improper Limitation of a Pathname to a Restricted Directory
CVE
CVE-2025-10268
View all Printcart Store – Web to Print Product Designer for WooCommerce vulnerabilities

At a glance

CVE-2025-10268 is a medium-severity Improper Limitation of a Pathname to a Restricted Directory vulnerability in the Printcart Store WordPress plugin, affecting versions <= 2.5.1. It carries a CVSS score of 5.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 2.5.2; sites on affected versions should update now. Disclosed June 2026, reported by D01EXPLOIT OFFICIAL.

Vulnerability Overview

The Printcart Web to Print Product Designer for WooCommerce plugin for WordPress is vulnerable to Directory Traversal in versions up to, and including, 2.5.1. This is due to insufficient validation of a user supplied path. This makes it possible for unauthenticated attackers to list directories on the server.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.

CWE-22: Improper Limitation of a Pathname to a Restricted Directory

Reaching this weakness in Printcart Store <= 2.5.1 takes no account at all. Path traversal happens when user-controlled text is used to build a filesystem path without being constrained to an intended directory, so sequences like ../ walk the resolved path somewhere else.

Depending on the operation, it means reading files outside the intended folder — wp-config.php being the usual target — or writing to and deleting paths the web server can touch. For Printcart Store the fix is 2.5.2: builds <= 2.5.1 are affected, anything from 2.5.2 onward is not.

Remediation

Update to version 2.5.2, or a newer patched version

How does WordSec protect against this?

Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Printcart Store 2.5.2 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C