CVE-2025-57917

Printcart Web to Print Product Designer for WooCommerce <= 2.13.2 - Missing Authorization

2025-09-22 00:00
Nguyen Xuan Chien

Strategic Overview

Status
Patched in 2.13.3
Affected Version
<= 2.13.2
CVSS
6.5Medium
Weakness type
CWE-862 · Missing Authorization
CVE
CVE-2025-57917
View all Printcart Store – Web to Print Product Designer for WooCommerce vulnerabilities

At a glance

CVE-2025-57917 is a medium-severity Missing Authorization vulnerability in the Printcart Store WordPress plugin, affecting versions <= 2.13.2. It carries a CVSS score of 6.5 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 2.13.3; sites on affected versions should update now. Disclosed September 2025, reported by Nguyen Xuan Chien.

Vulnerability Overview

The Printcart Web to Print Product Designer for WooCommerce plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on a function in versions up to, and including, 2.13.2. This makes it possible for unauthenticated attackers to perform an unauthorized action.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.

CWE-862: Missing Authorization

Reaching this weakness in Printcart Store <= 2.13.2 takes a caller who can reach the endpoint. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.

Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For Printcart Store the fix is 2.13.3: builds <= 2.13.2 are affected, anything from 2.13.3 onward is not.

Remediation

Update to version 2.13.3, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Printcart Store 2.13.3 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C