CVE-2026-19803

Printcart Store <= 2.13.2 - Unauthenticated Arbitrary File Upload via nbu_crop_image 'url' Parameter

2026-11-06 15:17
nudien

Strategic Overview

Status
Patched in 2.13.3
Affected Version
<= 2.13.2
CVSS
9.8Critical
Weakness type
CWE-94 · Improper Control of Generation of Code
CVE
CVE-2026-19803
View all Printcart Store – Web to Print Product Designer for WooCommerce vulnerabilities

At a glance

CVE-2026-19803 is a critical-severity Improper Control of Generation of Code vulnerability in the Printcart Store WordPress plugin, affecting versions <= 2.13.2. It carries a CVSS score of 9.8 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). Exploitation requires no authentication. The issue is fixed in version 2.13.3; sites on affected versions should update now. Disclosed November 2026, reported by nudien.

Vulnerability Overview

The Printcart Store – Web to Print Product Designer for WooCommerce plugin for WordPress is vulnerable to Arbitrary File Upload in all versions up to, and including, 2.13.2. This is due to the `nbu_crop_image` AJAX handler accepting a user-supplied `url` parameter that `Nbdesigner_IO::convert_url_to_path()` concatenates onto the uploads base directory without normalizing or stripping `../` sequences, and then deriving both the output directory and output file extension via `pathinfo()` from the same attacker-controlled path — with no `stripImage()` call before `writeImage()` is invoked. This makes it possible for unauthenticated attackers to write attacker-controlled PHP content to arbitrary locations outside the uploads directory, resulting in remote code execution when the written file is subsequently requested. This vulnerability is only exploitable when the `nbdesigner_upload_popup_style` site option is set to `a` (Advanced Upload Popup), which causes the handler to be registered for unauthenticated requests; however, the required `save-design` nonce is printed on the fully public frontend `upload-design-file` page, making it trivially obtainable by any anonymous visitor once that configuration is active.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.

CWE-94: Improper Control of Generation of Code

Printcart Store <= 2.13.2 carries this weakness at convert_url_to_path(), and reaching it takes no account at all. Code injection means input from a request reaches a language construct that evaluates code, so the attacker's text is executed rather than treated as data.

The injected code runs with the web server's privileges, giving the attacker the same access to the database and filesystem as WordPress itself. For Printcart Store the fix is 2.13.3: builds <= 2.13.2 are affected, anything from 2.13.3 onward is not.

Remediation

Update to version 2.13.3, or a newer patched version

How does WordSec protect against this?

Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. Classes like this one can leave something behind, so the staged malware scanner is the second half: it looks for dropped files and modified code rather than for the request that created them. None of that substitutes for the fix: Printcart Store 2.13.3 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Scanner
  • Login Security

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C