CVE-2026-116563

Photo Gallery, Sliders, Proofing and Themes <= 4.5.4 - Unauthenticated Stored DOM-Based Cross-Site Scripting via Comment `title` Attribute via Shutter Lightbox innerHTML

2026-10-30 17:16
UKO

Strategic Overview

Status
Patched in 4.5.5
Affected Version
<= 4.5.4
CVSS
5.4Medium
Weakness type
CWE-79 · Improper Neutralization of Input During Web Page Generation
CVE
CVE-2026-116563
View all Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery vulnerabilities

At a glance

CVE-2026-116563 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the Photo Gallery, Sliders, Proofing and Themes WordPress plugin, affecting versions <= 4.5.4. It carries a CVSS score of 5.4 (reachable over the network). Exploitation requires no authentication. The issue is fixed in version 4.5.5; sites on affected versions should update now. Disclosed October 2026, reported by UKO.

Vulnerability Overview

The Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 4.5.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires the site to have Shutter or Shutter Reloaded selected as the active lightbox, and the injected comment must be approved through WordPress's standard moderation workflow before the payload is rendered to other visitors.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, and no privileges on the target site, and no interaction from a victim user.

CWE-79: Improper Neutralization of Input During Web Page Generation

Photo Gallery, Sliders, Proofing and Themes <= 4.5.4 carries this weakness at comment, and reaching it takes no account at all. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.

Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For Photo Gallery, Sliders, Proofing and Themes the fix is 4.5.5: builds <= 4.5.4 are affected, anything from 4.5.5 onward is not.

Remediation

Update to version 4.5.5, or a newer patched version

How does WordSec protect against this?

Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Photo Gallery, Sliders, Proofing and Themes 4.5.5 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C