CVE-2026-76010

Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery <= 4.4.1 - Authenticated (Custom+) Remote Code Execution via XML-RPC 'meta_data' Mass Assignment and Path Traversal

2026-10-30 21:10
khanhnv

Strategic Overview

Status
Patched in 4.5.0
Affected Version
<= 4.4.1
CVSS
8.8High
Weakness type
CWE-434 · Unrestricted Upload of File with Dangerous Type
CVE
CVE-2026-76010
View all Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery vulnerabilities

At a glance

CVE-2026-76010 is a high-severity Unrestricted Upload of File with Dangerous Type vulnerability in the Photo Gallery, Sliders, Proofing and Themes WordPress plugin, affecting versions <= 4.4.1. It carries a CVSS score of 8.8 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). Exploitation requires an authenticated account at Custom level or above. The issue is fixed in version 4.5.0; sites on affected versions should update now. Disclosed October 2026, reported by khanhnv.

Vulnerability Overview

The Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.4.1 via the render_image function. This is due to unrestricted mass assignment of caller-supplied meta_data keys onto the image model combined with missing realpath containment in path construction and a bypassable signature check on the public image delivery route. This makes it possible for authenticated attackers, with custom-level access and above, to execute code on the server. Exploitation requires the authenticated attacker to own at least one NextGEN gallery — a condition that can be satisfied by any Subscriber who was ever granted the 'NextGEN Manage gallery' capability, and that access is retained indefinitely due to the stored gallery-author equality fallback in _can_manage_gallery() even after the capability is revoked.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.

CWE-434: Unrestricted Upload of File with Dangerous Type

Photo Gallery, Sliders, Proofing and Themes <= 4.4.1 carries this weakness at _can_manage_gallery(), and reaching it takes an account at Custom level or above. An unrestricted file upload lets a caller store a file whose type or destination the application does not properly constrain.

If an uploaded file lands anywhere the server will execute, the flaw becomes remote code execution and the site should be treated as fully compromised. For Photo Gallery, Sliders, Proofing and Themes the fix is 4.5.0: builds <= 4.4.1 are affected, anything from 4.5.0 onward is not.

Remediation

Update to version 4.5.0, or a newer patched version

How does WordSec protect against this?

An attacker needs Custom access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. Classes like this one can leave something behind, so the staged malware scanner is the second half: it looks for dropped files and modified code rather than for the request that created them. None of that substitutes for the fix: Photo Gallery, Sliders, Proofing and Themes 4.5.0 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Scanner
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C