Photo Gallery, Sliders, Proofing and Themes <= 4.4.1 - Authenticated (Custom+) Local File Inclusion via Lightroom 'gallery_edit' Task property_list + Image Upload
Strategic Overview
- Status
- Patched in 4.5.0
- Affected Version
<= 4.4.1- CVSS
- 7.5High
- Weakness type
- CWE-434 · Unrestricted Upload of File with Dangerous Type
- CVE
CVE-2026-76012
At a glance
CVE-2026-76012 is a high-severity Unrestricted Upload of File with Dangerous Type vulnerability in the Photo Gallery, Sliders, Proofing and Themes WordPress plugin, affecting versions <= 4.4.1. It carries a CVSS score of 7.5 (reachable over the network; high confidentiality, integrity, availability impact). Exploitation requires an authenticated account at Custom level or above. The issue is fixed in version 4.5.0; sites on affected versions should update now. Disclosed October 2026, reported by khanhnv.
Vulnerability Overview
The Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.4.1 via the legacy_render function. This is due to broken authorization on the Lightroom gallery_edit endpoint combined with mass assignment of gallery path and unrestricted file upload into a registered template directory, whose extension check uses a substring match that accepts sanitized .php_ filenames as valid templates. This makes it possible for authenticated attackers, with custom-level access and above, to execute code on the server. Exploitation requires the authenticated attacker to be the stored author of at least one existing NextGEN gallery, as ownership of that gallery is the sole authorization check gating the mass-assignment and upload steps.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.
CWE-434: Unrestricted Upload of File with Dangerous Type
Reaching this weakness in Photo Gallery, Sliders, Proofing and Themes <= 4.4.1 takes an account at Custom level or above. An unrestricted file upload lets a caller store a file whose type or destination the application does not properly constrain.
If an uploaded file lands anywhere the server will execute, the flaw becomes remote code execution and the site should be treated as fully compromised. For Photo Gallery, Sliders, Proofing and Themes the fix is 4.5.0: builds <= 4.4.1 are affected, anything from 4.5.0 onward is not.
Remediation
Update to version 4.5.0, or a newer patched version
How does WordSec protect against this?
An attacker needs Custom access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. Classes like this one can leave something behind, so the staged malware scanner is the second half: it looks for dropped files and modified code rather than for the request that created them. None of that substitutes for the fix: Photo Gallery, Sliders, Proofing and Themes 4.5.0 closes this, and updating the plugin is the step that ends it.
- Firewall
- Scanner
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery
- 9.8CVE-2019-14314: NextGEN Gallery <= 3.2.10 SQL Injection
CVE-2019-14314 - 9.8CVE-2016-10889: NextGEN Gallery <= 2.1.56 LFI & SQL injection
CVE-2016-10889 - 8.8CVE-2026-1463: Photo Gallery LFI
CVE-2026-1463 - 8.8CVE-2025-13641: Photo Gallery LFI
CVE-2025-13641 - 8.8CVE-2020-35942: WordPress Gallery Plugin – NextGEN Gallery CSRF
CVE-2020-35942 - 8.8CVE-2020-35943: WordPress Gallery Plugin CSRF to Arbitrary File Upload
CVE-2020-35943 - 8.8Freemius SDK <= 2.2.3 Arbitrary Options Update
- 8.8NextGen Gallery <= 3.1.5 PHP Object Injection
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C