MasterStudy LMS WordPress Plugin – for Online Courses and Education <= 3.7.49 - Authenticated (Custom+) Path Traversal
Strategic Overview
- Status
- Patched in 3.7.50
- Affected Version
<= 3.7.49- CVSS
- 4.3Medium
- Weakness type
- CWE-22 · Improper Limitation of a Pathname to a Restricted Directory
- CVE
CVE-2026-80067
At a glance
CVE-2026-80067 is a medium-severity Improper Limitation of a Pathname to a Restricted Directory vulnerability in the MasterStudy LMS WordPress Plugin WordPress plugin, affecting versions <= 3.7.49. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Custom level or above. The issue is fixed in version 3.7.50; sites on affected versions should update now. Disclosed October 2026, reported by Jon Bytyçi.
Vulnerability Overview
The MasterStudy LMS WordPress Plugin – for Online Courses and Education plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 3.7.49. This is due to insufficient validation of a user supplied path. This makes it possible for authenticated attackers to access files and directories outside of the intended directory.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-22: Improper Limitation of a Pathname to a Restricted Directory
Reaching this weakness in MasterStudy LMS WordPress Plugin <= 3.7.49 takes an account at Custom level or above. Path traversal happens when user-controlled text is used to build a filesystem path without being constrained to an intended directory, so sequences like ../ walk the resolved path somewhere else.
Depending on the operation, it means reading files outside the intended folder — wp-config.php being the usual target — or writing to and deleting paths the web server can touch. For MasterStudy LMS WordPress Plugin the fix is 3.7.50: builds <= 3.7.49 are affected, anything from 3.7.50 onward is not.
Remediation
Update to version 3.7.50, or a newer patched version
How does WordSec protect against this?
An attacker needs Custom access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: MasterStudy LMS WordPress Plugin 3.7.50 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in MasterStudy LMS WordPress Plugin – for Online Courses and Education
- 9.8CVE-2024-3136: MasterStudy LMS <= 3.3.3 Local File Inclusion
CVE-2024-3136 - 9.8CVE-2024-2409: MasterStudy LMS <= 3.3.1 Privilege Escalation
CVE-2024-2409 - 9.8CVE-2024-2411: MasterStudy LMS <= 3.3.0 Local File Inclusion
CVE-2024-2411 - 9.8CVE-2024-1512: MasterStudy LMS WordPress Plugin SQL Injection
CVE-2024-1512 - 9.8CVE-2022-0441: MasterStudy LMS < 2.7.6 Admin Account Creation
CVE-2022-0441 - 8.8CVE-2025-32141: MasterStudy LMS <= 3.5.28 Local File Inclusion
CVE-2025-32141 - 7.5CVE-2026-118090: MasterStudy LMS WordPress Plugin PHP Object Injection
CVE-2026-118090 - 7.3CVE-2024-5973: MasterStudy LMS WordPress… Limited Privilege Escalation
CVE-2024-5973
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C