MasterStudy LMS WordPress Plugin – for Online Courses and Education <= 3.7.55 - Authenticated (Subscriber+) PHP Object Injection
Strategic Overview
- Status
- Patched in 3.7.56
- Affected Version
<= 3.7.55- CVSS
- 7.5High
- Weakness type
- CWE-502 · Deserialization of Untrusted Data
- CVE
CVE-2026-118090
At a glance
CVE-2026-118090 is a high-severity Deserialization of Untrusted Data vulnerability in the MasterStudy LMS WordPress Plugin WordPress plugin, affecting versions <= 3.7.55. It carries a CVSS score of 7.5 (reachable over the network; high confidentiality, integrity, availability impact). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 3.7.56; sites on affected versions should update now. Disclosed October 2026, reported by Siyang Wu.
Vulnerability Overview
The MasterStudy LMS WordPress Plugin – for Online Courses and Education plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 3.7.55. This is due to deserialization of untrusted input. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject a PHP Object. No known POP chain is present in the vulnerable software. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.
CWE-502: Deserialization of Untrusted Data
Reaching this weakness in MasterStudy LMS WordPress Plugin <= 3.7.55 takes an account at Subscriber level or above. Deserialization of untrusted data means the application reconstructs objects from input a caller controls, letting the attacker choose which classes get instantiated and what their properties hold.
A workable chain turns deserialization into file writes, deletions or code execution, depending on what the loaded classes do in their magic methods. For MasterStudy LMS WordPress Plugin the fix is 3.7.56: builds <= 3.7.55 are affected, anything from 3.7.56 onward is not.
Remediation
Update to version 3.7.56, or a newer patched version
How does WordSec protect against this?
An attacker needs Subscriber access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. Classes like this one can leave something behind, so the staged malware scanner is the second half: it looks for dropped files and modified code rather than for the request that created them. None of that substitutes for the fix: MasterStudy LMS WordPress Plugin 3.7.56 closes this, and updating the plugin is the step that ends it.
- Firewall
- Scanner
- Alerts
External References
Related records
Other vulnerabilities in MasterStudy LMS WordPress Plugin – for Online Courses and Education
- 9.8CVE-2024-3136: MasterStudy LMS <= 3.3.3 Local File Inclusion
CVE-2024-3136 - 9.8CVE-2024-2409: MasterStudy LMS <= 3.3.1 Privilege Escalation
CVE-2024-2409 - 9.8CVE-2024-2411: MasterStudy LMS <= 3.3.0 Local File Inclusion
CVE-2024-2411 - 9.8CVE-2024-1512: MasterStudy LMS WordPress Plugin SQL Injection
CVE-2024-1512 - 9.8CVE-2022-0441: MasterStudy LMS < 2.7.6 Admin Account Creation
CVE-2022-0441 - 9.1CVE-2026-78284: MasterStudy LMS WordPress… Arbitrary File Deletion
CVE-2026-78284 - 8.8CVE-2025-32141: MasterStudy LMS <= 3.5.28 Local File Inclusion
CVE-2025-32141 - 7.5CVE-2026-88843: MasterStudy LMS 3.5.29 - 3.7.49 Local File Inclusion
CVE-2026-88843
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C