LiteSpeed Cache <= 7.9.1 - Unauthenticated Stored Cross-Site Scripting via HTML Minifier Predictable Placeholder (md5(REQUEST_TIME) + two-pass str_replace)
Strategic Overview
- Status
- Patched in 7.9.2
- Affected Plugin
- LiteSpeed Cache
- Affected Version
<= 7.9.1- CVSS
- 5.4Medium
- Weakness type
- CWE-79 · Improper Neutralization of Input During Web Page Generation
- CVE
CVE-2026-116763
At a glance
CVE-2026-116763 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the LiteSpeed Cache WordPress plugin, affecting versions <= 7.9.1. It carries a CVSS score of 5.4 (reachable over the network). Exploitation requires no authentication. The issue is fixed in version 7.9.2; sites on affected versions should update now. Disclosed October 2026, reported by Santh.
Vulnerability Overview
The LiteSpeed Cache plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 7.9.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is only exploitable when the HTML Minify option (O_OPTM_HTML_MIN) is enabled and a companion plugin renders stored comment content into a raw-text context such as a JSON-LD script block on the same page.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, and no privileges on the target site, and no interaction from a victim user.
CWE-79: Improper Neutralization of Input During Web Page Generation
LiteSpeed Cache <= 7.9.1 carries this weakness at comment, and reaching it takes no account at all. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.
Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For LiteSpeed Cache the fix is 7.9.2: builds <= 7.9.1 are affected, anything from 7.9.2 onward is not.
Remediation
Update to version 7.9.2, or a newer patched version
How does WordSec protect against this?
Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: LiteSpeed Cache 7.9.2 closes this, and updating the plugin is the step that ends it.
- Firewall
- Login Security
- Alerts
External References
Related records
Same weakness class
- 7.2CVE-2026-113500: LiteSpeed Cache < 7.9.2 Stored Cross-Site Scripting
CVE-2026-113500 - 7.2CVE-2026-113499: LiteSpeed Cache < 7.9.2 Stored Cross-Site Scripting
CVE-2026-113499 - 7.2CVE-2026-18978: LiteSpeed Cache <= 7.8.1 Stored Cross-Site Scripting
CVE-2026-18978 - 7.2CVE-2026-3375: LiteSpeed Cache <= 7.7 Stored Cross-Site Scripting
CVE-2026-3375
Other vulnerabilities in LiteSpeed Cache
- 9.8CVE-2024-28000: LiteSpeed Cache <= 6.3.0.1 Privilege Escalation
CVE-2024-28000 - 8.1CVE-2024-50550: LiteSpeed Cache <= 6.5.1 Privilege Escalation
CVE-2024-50550 - 7.5CVE-2024-44000: LiteSpeed Cache <= 6.4.1 Info Exposure
CVE-2024-44000 - 7.2CVE-2026-84761: LiteSpeed Cache <= 7.9 Server-Side Request Forgery
CVE-2026-84761 - 7.2CVE-2024-47374: LiteSpeed Cache <= 6.1 Stored Cross-Site Scripting
CVE-2024-47374 - 7.2CVE-2023-40000: LiteSpeed Cache <= 5.7 Stored Cross-Site Scripting
CVE-2023-40000 - 6.5CVE-2021-24964: LiteSpeed Cache <= 4.4.3 Authorization Bypass
CVE-2021-24964 - 6.4CVE-2026-109215: LiteSpeed Cache <= 7.9.1 Stored Cross-Site Scripting
CVE-2026-109215
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C